Ask Your Question
0

ovs gre tunnel problem. Dosent show up after ovs agent restart.

asked 2015-04-02 06:32:19 -0500

enojado gravatar image

Hi,

Im starting to get blind on my config.
After I started with neutron and ovs the "neutron agent-list" are down, and my physical host.

My environment is one vm with keystone db, rabbit, and nova and neutron db.
One vm which is a network node with three vmx network interfaces.
One physical host which is the compute node with two network interfaces.
All is ubuntu 1404 (updated) with juno.

Below you can see ml2 config, and logs.
I have also checked this: http://bderzhavets.blogspot.com/2014/...
And mysql db tabels have correct ip addresses for the gre tunnel.

The problem started after i started with OVS. The Gre - tunnel seems working from the beginning but after restarting the neutron-plugin-openvswitch-agent the gre tunnel do not showing up in the "ovs-vsctl show" -list. The neutron-plugin-openvswitch-agent service will not start on the network node, it still running on compute node.

I have following the doc for juno and ubuntu 1404.

From network node:
ovs-vsctl show
48423edd-029c-4628-9966-311f6158a53c
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth2"
            Interface "eth2"
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
    ovs_version: "2.0.2"








    From compute node
     ovs-vsctl show
80837ab9-473d-439c-bc05-9c362593b1dc
    Bridge br-int
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    Bridge br-tun
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port br-tun
            Interface br-tun
                type: internal
    ovs_version: "2.0.2"



 From network node
  vi /etc/neutron/plugins/ml2/ml2_conf.ini
[ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
integration_bridge = br-int
tunnel_bridge = br-tun

[ml2_type_flat]
flat_networks = external

[ml2_type_vlan]

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[ml2_type_vxlan]

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]
local_ip = 10.55.0.23
enable_tunneling = True
bridge_mappings = external:br-ex

[agent]
tunnel_types = gre


 From compute node
  vi /etc/neutron/plugins/ml2/ml2_conf.ini 
 [ml2]
type_drivers = gre
tenant_network_types = gre
mechanism_drivers = openvswitch
integration_bridge = br-int
tunnel_bridge = br-tun

[ml2_type_flat]

[ml2_type_vlan]

[ml2_type_gre]
tunnel_id_ranges = 1:1000

[ml2_type_vxlan]

[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]
local_ip = 10.55.0.38
enable_tunneling = True

[agent]
tunnel_types = gre


The log from network node.
cat /var/log/neutron/openvswitch-agent.log
...
2015-04-01 20:42:06.261 24898 INFO oslo.messaging._drivers.impl_rabbit [req-da830576-add3-4b50-926b-cc0b36c69714 ] Connected to AMQP server on 10.55.0.28:5672
2015-04-01 20:42:06.268 24898 INFO oslo.messaging._drivers.impl_rabbit [req-da830576-add3-4b50-926b-cc0b36c69714 ] Connecting to AMQP server on 10.55.0.28:5672
2015-04-01 20:42:06.276 24898 INFO oslo.messaging._drivers.impl_rabbit [req-da830576-add3-4b50-926b-cc0b36c69714 ] Connected to AMQP server on 10.55.0.28:5672
2015-04-01 20:42:06.282 24898 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-da830576-add3-4b50-926b-cc0b36c69714 None] Agent initialized successfully, now running...
2015-04-01 20:42:06.286 24898 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-da830576-add3-4b50-926b-cc0b36c69714 None] Agent out of sync ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2015-04-02 09:06:42 -0500

Charles Benon gravatar image

Hi Enojado,

I have the exact same setup in my lab.

I don't see you gre interface on ovs, so, it looks like neutron can't creat them:

Bridge br-tun
    Port br-tun
        Interface br-tun
            type: internal
    Port "gre-0a000129"
        Interface "gre-0a000129"
            type: gre
            options: {df_default="true", in_key=flow, local_ip="10.0.1.21", out_key=flow, remote_ip="10.0.1.41"

Could you get ride of those 2 lines (I don't have them and don't see them in Juno doc) in ml2_conf.ini and restart neutron/ovs services on both of the nodes:

  • integration_bridge = br-int
  • tunnel_bridge = br-tun
edit flag offensive delete link more

Comments

Hello Sir, thank you very much.
I know i dont need openvswitch-datapath-dkms for juno, but i installed it anyway on both network and compute. Removed the lines you telling me to remove.
Removed openvswitch-datapath-dkms again from network node. Suddenly gre tunnel is open !!

enojado gravatar imageenojado ( 2015-04-02 13:29:02 -0500 )edit

The only different tonights setup is comparing yesterday is openvswitch-datapath-dkms in compute node. I know there is nothing to with dkms package, but its strange. I need to know why this working now and not yesterday.

enojado gravatar imageenojado ( 2015-04-02 13:31:34 -0500 )edit

I have one error from openvswitch-neutron-agent.log
ERROR neutron.agent.linux.ovsdb_monitor Error received from ovsdb monitor: sudo: unable to resolve host vitkencas03
Have you seen it before?

enojado gravatar imageenojado ( 2015-04-02 13:33:07 -0500 )edit

And I get this warning in controller in .../neutron/server.log
Gre endpoint with ip 10.55.0.38 already exists
Gre endpoint with ip 10.55.0.23 already exists

enojado gravatar imageenojado ( 2015-04-02 13:37:16 -0500 )edit

dah, of course. etc/hosts added 127.0.0.1 localhost <network-node>

enojado gravatar imageenojado ( 2015-04-02 14:52:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-02 06:32:19 -0500

Seen: 2,255 times

Last updated: Apr 02 '15