Ask Your Question
0

You are not authorized to perform the requested action: admin_required (Disable debug mode to suppress these details.)

asked 2015-04-02 05:07:43 -0600

Nicholas I gravatar image

Hi,

I am using juno and installed it through devstack.

when i try any commands like given below, i get the following error message.

keystone service-list

You are not authorized to perform the requested action: admin_required (Disable debug mode to suppress these details.) (HTTP 403) (Request-ID asdfasfsdff979)

Note: i have sourced openrc as admin.

edit retag flag offensive close merge delete

Comments

Can you post more info & logs to troubleshoot the issue.

SGPJ gravatar imageSGPJ ( 2015-04-02 06:42:36 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-04-03 04:19:25 -0600

Have you sourced the admin keystone rc file?

[root@junoOS-controller ~]# source keystonerc_admin

Only then you could run the keystone command without errors...

edit flag offensive delete link more
0

answered 2016-01-27 08:08:04 -0600

jckreddy gravatar image

Hi

you should have admin credentials to execute the "keystone service-list" command cat admin-openrc.sh export OS_PROJECT_DOMAIN_ID=default export OS_USER_DOMAIN_ID=default export OS_PROJECT_NAME=admin export OS_TENANT_NAME=admin export OS_USERNAME=admin export OS_PASSWORD=changeit export OS_AUTH_URL=http://${HOSTNAME}:35357/v3 export OS_IMAGE_API_VERSION=2 export OS_VOLUME_API_VERSION=2

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-02 05:07:43 -0600

Seen: 3,475 times

Last updated: Apr 03 '15