Ask Your Question
1

Cannot Open Instance Console

asked 2015-04-01 07:45:39 -0600

Silvia gravatar image

Hi, I have installed Openstack through Devstack in a virtual machine in a remote server and I use ssh to access. I have a problem when I try to open the istance console: I can see the message: " If console is not responding to keyboard input: click the grey status bar below. Click here to show only console To exit the fullscreen mode, click the browser's back button." But below this message there is just a white page. No error messages, absolutely nothing! I don't think it's an iptables problem because yesterday I used the console from another network and the same laptop.

Moreover when I'm connected to the machine in which I have installed openstack through ssh it freezes. I can't use it. If I just wait some time ssh get disconnected and I can read the message: "stack@devstack:~$ Write failed: Broken pipe" and I have to connect to my server again.

Can someone help me please? Thank you kind regards Silvia

edit retag flag offensive close merge delete

Comments

What kind of machine are you running this on (hardware specs)? Have you tried alternate browsers like Firefox(Sounds dumb but Chrome isn't always the best for VNC console) have you tried switching to the spice console? http://docs.openstack.org/admin-guide...

omar-munoz gravatar imageomar-munoz ( 2015-04-01 10:28:44 -0600 )edit

My university has a mini data center where they built for me a VM where they have installed OpenStack. I don't know hw details about it. My laptop has 4GB RAM, and I'm using Ubuntu 14.04. I have used both firefox and chrome. I had no problem when I was connected on the same network of the server.

Silvia gravatar imageSilvia ( 2015-04-01 10:51:47 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-01 11:39:34 -0600

Check your local.conf file (within Devstack's root directory) - is the n-novnc service enabled? It used to be enabled by default, but isn't any more.

You're looking for a line like this:

disable_service n-novnc

Change that to:

enable_service n-novnc
edit flag offensive delete link more

Comments

There was no line related to n-novnc but I've added what you suggested. Than I have unstack, clean, removed the folder /opt/stack and I have ./stack. Nothing is changed. I've also tried to get a console through the command, when I copy the link in my browser it does not load anything.

Silvia gravatar imageSilvia ( 2015-04-02 02:46:00 -0600 )edit

When you try and open a console... is there a vnc process running? ('ps aux |grep -i vnc')

If there is, this is connectivity problem. If there isn't, this is a configuration problem.

tedlit gravatar imagetedlit ( 2015-04-02 09:22:28 -0600 )edit
0

answered 2015-04-21 10:40:31 -0600

Silvia gravatar image

It's just a networking problem. I'm connected to my vm in which is installed Openstack via ssh from an external network. Thanks to all.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-04-01 07:45:39 -0600

Seen: 2,169 times

Last updated: Apr 21 '15