Ask Your Question
0

unable ping google from instance

asked 2015-04-01 02:32:34 -0500

amitabh sinha gravatar image

I have allinone juno setup. I am able to do ssh into instance but when I am trying to reach google it is showing unknown host.

edit retag flag offensive close merge delete

Comments

Please explain us what are the troubleshooting steps you have taken like DNS ping from VM?

SGPJ gravatar imageSGPJ ( 2015-04-01 02:46:28 -0500 )edit

I have set the mtu of an instance to 1400 . And it worked for me. Now I am able to ping the vm and ssh to it. Even I am able to ping the gateway from the instance but unable to ping google.com from it.

amitabh sinha gravatar imageamitabh sinha ( 2015-04-01 03:26:33 -0500 )edit

Are you able to ping IP address of google? For example, in my laptop, if I run the command "ping google.com", I see below message : Reply from 173.194.36.3: bytes=32 time=22ms TTL=54 Reply from 173.194.36.3: bytes=32 time=22ms TTL=54

So, in my case, the IP of google is 173.194.36.3.

teju gravatar imageteju ( 2015-04-21 01:44:20 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
1

answered 2015-04-28 01:38:50 -0500

Vinoth gravatar image

Add the following line in /etc/resolv.conf file.

 nameserver 8.8.8.8 
 nameserver 8.8.4.4
edit flag offensive delete link more

Comments

I had nameserver 192.168.0.2 and nameserver 192.168.0.3 in my resolv.conf changed them and everything is working now!

vladkras gravatar imagevladkras ( 2017-03-23 14:34:15 -0500 )edit
0

answered 2015-04-01 03:12:41 -0500

RHK gravatar image

Amitabh,

are you able to ping your gateway?

once check # route -n

Regards,
RHK

edit flag offensive delete link more

Comments

yes I am able to ping . I have checked the route -n as well. Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 50.50.1.1 0.0.0.0 UG 0 0 0 eth0 50.50.1.0 0.0.0.0 255.255.255.0 U 0

amitabh sinha gravatar imageamitabh sinha ( 2015-04-01 03:17:50 -0500 )edit
0

answered 2015-04-01 02:43:14 -0500

Sahana gravatar image

I had the same issue, try to re-add the NAT Interface then reboot the system. And once check with Network interface configuration file.

edit flag offensive delete link more

Comments

content of vi /etc/network/interfaces auto lo iface lo inet loopback

auto eth0 iface eth0 inet dhcp

how to re-add the nat interface? Thanks in advance

amitabh sinha gravatar imageamitabh sinha ( 2015-04-01 03:21:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-04-01 02:32:34 -0500

Seen: 864 times

Last updated: Apr 28 '15