Ask Your Question
0

rdo repository unable to add

asked 2015-03-31 13:00:52 -0500

madejackson gravatar image

I Can't add the RDO-repository on a fresh CentOS 7 install. Any Ideas? I got this error:

Loaded plugins: fastestmirror
Repository 'openstack-juno': Error parsing config: Error parsing "baseurl = 'http://repos.fedorapeople.org/repos/openstack/openstack-juno/epel-Derived from Red Hat Enterprise Linux 7.1 (Source)/'": URL must be http, ftp, file or https not ""
Cannot open: https://rdo.fedorapeople.org/rdo-release.rpm. Skipping.
Error: Nothing to do
edit retag flag offensive close merge delete

Comments

Have you run yum -y update before ?

dbaxps gravatar imagedbaxps ( 2015-03-31 13:24:20 -0500 )edit

i have the same issue , just installed centos 7.0 and also ran yum update -y

test02 gravatar imagetest02 ( 2015-03-31 13:39:43 -0500 )edit

Yes, I did every step listed in the Quickstart guide. I think the problem is because the repo tries to open the dir epel-Derived/ but on http://fedorapeople.org there is only a epel-7/ dir.

madejackson gravatar imagemadejackson ( 2015-03-31 13:50:59 -0500 )edit

I am experiencing the same issue. The rpm has errors, I hope somebody can fix it soon

Eduardo gravatar imageEduardo ( 2015-03-31 14:07:11 -0500 )edit

Well how do I edit a RPM-File?

madejackson gravatar imagemadejackson ( 2015-03-31 14:54:01 -0500 )edit

6 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-31 21:15:52 -0500

You need to edit the yum repo file as Renato described in his answer. Then you may run into another packstack problem with missing packages as test02 described. It appears that some puppet scripts are reading /etc/redhat-release and not acting properly because the file format just changed. If you copy /etc/centos-release to /etc/redhat-release (save it off somewhere), and also turn off NetworkManager, you may be able to run packstack on CentOS 7.1 as I just did. (Its probably a good idea to restore /etc/redhat-release afterwards.)

edit flag offensive delete link more
0

answered 2015-03-31 15:18:19 -0500

Renato-Armani gravatar image

Just, replace the baseurl address in the repofile like that:

Edit: vim /etc/yum.repos.d/rdo-release.repo

Replace: baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-juno/epel-Derived from Red Hat Enterprise Linux 7.1 (Source)/ for: baseurl=http://repos.fedorapeople.org/repos/openstack/openstack-juno/epel-7/

It worked for me!

edit flag offensive delete link more

Comments

i replaced the url ,was able to get packstack downloaded, when i run packstack , it gives No package puppet available. No package hiera available.

test02 gravatar imagetest02 ( 2015-03-31 17:46:15 -0500 )edit
0

answered 2015-03-31 14:56:13 -0500

madejackson gravatar image

I think I found the issue. Since RHEL is updated to 7.1, CentOS is now on Centos 7.1, too. So the RPM does not recognize the correct version of CentOS. Any Ideas?

edit flag offensive delete link more
0

answered 2015-03-31 14:10:30 -0500

dbaxps gravatar image

Just update repo file with baseurl containing "epel-7/" and see what happens ?

edit flag offensive delete link more
0

answered 2015-03-31 13:38:44 -0500

test02 gravatar image

i have the same issue , How ever i did run yum update -y

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-03-31 13:00:52 -0500

Seen: 1,685 times

Last updated: Mar 31 '15