devstack installation failed at verify-tempest-configure

asked 2015-03-31 04:12:13 -0500

zzhao gravatar image

I'm trying to use Heat to install devstack with a RHEL7.1 KVM guest image. The part of Heat template looks like below:

    write_files:
      - content: |
            #!/bin/sh
            DEBIAN_FRONTEND=noninteractive sudo yum install -y git
            sudo chown stack:stack /home/stack
            cd /home/stack
            git clone https://git.openstack.org/openstack-dev/devstack
            cd devstack
            echo '[[local|localrc]]' > local.conf
            echo 'GIT_BASE=${GIT_BASE:-https://git.openstack.org}' >> local.conf
            echo ADMIN_PASSWORD=password >> local.conf
            echo MYSQL_PASSWORD=password >> local.conf
            echo RABBIT_PASSWORD=password >> local.conf
            echo SERVICE_PASSWORD=password >> local.conf
            echo SERVICE_TOKEN=tokentoken >> local.conf
            ./stack.sh
        path: /home/stack/start.sh
        permissions: 0755

    runcmd:
      - su -l stack ./start.sh

It always failed at venv test of verify-tempest-configure:

Mar 30 18:40:52 os-juno-2-server-giu73ttrct3f cloud-init: ++ local tmp_cfg_file=/tmp/tmp.1cUJ1uNGCj Mar 30 18:40:52 os-juno-2-server-giu73ttrct3f cloud-init: ++ cd /opt/stack/tempest Mar 30 18:40:52 os-juno-2-server-giu73ttrct3f cloud-init: ++ tox -revenv -- verify-tempest-config -uro /tmp/tmp.1cUJ1uNGCj Mar 30 18:40:52 os-juno-2-server-giu73ttrct3f cloud-init: venv create: /opt/stack/tempest/.tox/venv Mar 30 18:40:53 os-juno-2-server-giu73ttrct3f cloud-init: venv installdeps: -r/opt/stack/tempest/requirements.txt, -r/opt/stack/tempest/test-requirements.txt Mar 30 18:42:25 os-juno-2-server-giu73ttrct3f cloud-init: venv develop-inst: /opt/stack/tempest Mar 30 18:42:30 os-juno-2-server-giu73ttrct3f cloud-init: venv runtests: PYTHONHASHSEED='3643650365' Mar 30 18:42:30 os-juno-2-server-giu73ttrct3f cloud-init: venv runtests: commands[0] | verify-tempest-config -uro ../../../tmp/tmp.1cUJ1uNGCj Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: Running config verification... Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: ERROR: InvocationError: '/opt/stack/tempest/.tox/venv/bin/verify-tempest-config -uro ../../../tmp/tmp.1cUJ1uNGCj' Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: ___________________________________ summary ____________________________________ Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: ERROR: venv: commands failed Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + exit_trap Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + local r=1 Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: ++ jobs -p Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + jobs= Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + [[ -n '' ]] Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + kill_spinner Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + '[' '!' -z '' ']' Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + [[ 1 -ne 0 ]] Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + echo 'Error on exit' Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: Error on exit Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + [[ -z /opt/stack/logs ]] Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + /home/stack/devstack/tools/worlddump.py -d /opt/stack/logs Mar 30 18:43:47 os-juno-2-server-giu73ttrct3f cloud-init: + exit 1 Mar 30 18:43:48 os-juno-2-server-giu73ttrct3f cloud-init: 2015-03-30 18:43:47,342 - util.py[WARNING]: Failed running /var/lib/cloud/instance/scripts/runcmd [1]

I checked that the tmp file /tmp/tmp.1cUJ1uNGCj has 0 byte. What could be the problem?

Thanks

edit retag flag offensive close merge delete

Comments

I'm also seeing the same failure on Ubuntu 14.04. I've had to "disable_service tempest" in my local.conf to get beyond this issue, but, would like to understand why tempest is failing here. Note: the Ubuntu 14.04 is a desktop VM instance in Virtualbox.

wayne-okuma gravatar imagewayne-okuma ( 2015-04-20 20:44:32 -0500 )edit

I am also facing same issue ..Is there any other workaround ? apart form disabling tempest

Sangram Roy gravatar imageSangram Roy ( 2015-09-15 03:25:42 -0500 )edit

do we just add "disable_service tempest" in the local.conf ?

aditya28 gravatar imageaditya28 ( 2016-02-11 22:02:52 -0500 )edit