Ask Your Question
0

Default volume-type for Cinder volumes ?

asked 2015-03-30 07:18:53 -0500

Jorge Florencio gravatar image

Hi, I have two backends configured in Cinder:

[DEFAULT]
...
default_volume_type=lvm
enabled_backends=lvm,scaleio

[lvm]
...
volume_driver=cinder.volume.drivers.lvm.LVMISCSIDriver
volume_backend_name=LVM_iSCSI

[scaleio]
...
volume_driver=cinder.volume.drivers.emc.scaleio.ScaleIODriver
volume_backend_name=ScaleIO

I have created two volume types, one per each backend.

# cinder type-list
+--------------------------------------+---------+
|                  ID                  |   Name  |
+--------------------------------------+---------+
| cb87ac68-7f17-4c3a-b5d3-a23daaa30549 | scaleio |
| f66dd86d-f32e-4d31-a7b5-5f8528d02ae4 |   lvm   |
+--------------------------------------+---------+

# cinder extra-specs-list
+--------------------------------------+---------+---------------------------------------------------------------------------------------------------------------------------------+
|                  ID                  |   Name  |                                                           extra_specs                                                           |
+--------------------------------------+---------+---------------------------------------------------------------------------------------------------------------------------------+
| cb87ac68-7f17-4c3a-b5d3-a23daaa30549 | scaleio | {u'sio:pd_name': u'domain1', u'sio:provisioning_type': u'thin', u'sio:sp_name': u'default', u'volume_backend_name': u'ScaleIO'} |
| f66dd86d-f32e-4d31-a7b5-5f8528d02ae4 |   lvm   |                                              {u'volume_backend_name': u'LVM_iSCSI'}                                             |
+--------------------------------------+---------+---------------------------------------------------------------------------------------------------------------------------------+

I create a volume without especifying the volume type and then the volume is created using "scaleio" volume type, instead of "lvm" volume type.

Why parameter "default_volume_type" in cinder.conf is being ignored?

Thank you, Jorge

edit retag flag offensive close merge delete

Comments

I'm not familiar with 'scaleio' what instructions did you use to set this up, so we have an idea of what you are working with.

omar-munoz gravatar imageomar-munoz ( 2015-03-30 13:23:41 -0500 )edit

I have this problem too! I have restarted services and even removed other enabled backends from enabled_backends. I find that using the horizon dashboard to launch instances is working fine. But when using the cli, it uses the wrong backend.

tonyp12 gravatar imagetonyp12 ( 2018-02-23 02:27:41 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-02-20 06:42:06 -0500

when you run openstack volume service list command on openstack controller does it gives controller@scaleio up or down. Because in my case its showing down state and volume.log doesnt show any error. can you tell me are using the same username password for san_username and password ,the one we use to login in EMC scaleIO gui and ip for the gateway ip in cinder.conf

edit flag offensive delete link more
0

answered 2017-06-19 23:55:30 -0500

Have you ever restarted openstack-cinder-scheduler and openstack-cinder-volume services after changing the configuration file ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-30 07:18:53 -0500

Seen: 4,246 times

Last updated: Feb 20