Ask Your Question
1

Neutron Juno DHCP issue (SOLVED)

asked 2015-03-26 10:35:16 -0500

KoSuKe gravatar image

updated 2015-04-07 03:36:00 -0500

I've installed Juno on Ubuntu 14.04.2 LTS and instances can't get IP from DHCP. No errors in logs.

Network Node

root@network:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:50:56:b1:79:07 brd ff:ff:ff:ff:ff:ff
    inet 10.8.1.131/24 brd 10.8.1.255 scope global eth0
    valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:50:56:b1:2e:45 brd ff:ff:ff:ff:ff:ff
    inet 10.0.1.21/24 brd 10.0.1.255 scope global eth1
    valid_lft forever preferred_lft forever
4: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP group default qlen 1000
    link/ether 00:50:56:b1:12:ba brd ff:ff:ff:ff:ff:ff
5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default
    link/ether be:0e:db:dc:3d:56 brd ff:ff:ff:ff:ff:ff
6: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether 00:50:56:b1:12:ba brd ff:ff:ff:ff:ff:ff
9: br-int: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether d6:bf:05:38:7d:43 brd ff:ff:ff:ff:ff:ff
13: phy-br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 1a:74:47:c1:1b:1b brd ff:ff:ff:ff:ff:ff
14: int-br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master ovs-system state UP group default qlen 1000
    link/ether 9e:ae:d6:8e:e3:b0 brd ff:ff:ff:ff:ff:ff
15: br-tun: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether c6:7b:a3:9b:ea:4e brd ff:ff:ff:ff:ff:ff

root@network:~# ip netns
qrouter-eb218066-143d-42b4-ba90-0f719defde66
qdhcp-38639607-391a-4622-ac0e-37d5a32ced1b

root@network:~# ip netns exec qrouter-eb218066-143d-42b4-ba90-0f719defde66 ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
16: qr-3a45f5b8-01: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default
    link/ether fa:16:3e:a8:55:0b brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global qr-3a45f5b8-01
    valid_lft forever preferred_lft forever
    inet6 fe80::f816:3eff:fea8:550b/64 scope link
    valid_lft forever preferred_lft forever ...
(more)
edit retag flag offensive close merge delete

Comments

seems ok. Standard network troubleshooting is to dump along the path and see how far the packets are getting, you could start with tcpdump -eni eth1 udp port 67

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-03-28 02:27:50 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-04-07 03:34:34 -0500

KoSuKe gravatar image

updated 2015-04-07 03:43:04 -0500

It was something wrong with openvswitch. I upgraded it to 2.3.1 and it's still failing, then I removed openvswtich packages, deleted all directories of it, finally I reinstalled openvswitch 2.0.2 and it works.

It's not a DHCP issue, it's a openvswtich issue on compute node, if I configure static IPs on instances, on the same compute node, I can't ping between them.

edit flag offensive delete link more
-1

answered 2015-03-27 06:15:24 -0500

itarchitectkev gravatar image

Try changing the MTU to allow the extra bits of the tunnel to make into the tunnel packet due to DNSMasq requiring unfragmented packets.

cat > ${NEUTRON_DHCP_AGENT_INI} << EOF

[DEFAULT]

interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver

dhcp_driver = neutron.agent.linux.dhcp.Dnsmasq

use_namespaces = True

dnsmasq_config_file=/etc/neutron/dnsmasq-neutron.conf

EOF

cat > /etc/neutron/dnsmasq-neutron.conf << EOF

dhcp-option-force=26,1400

EOF

edit flag offensive delete link more

Comments

My dnsmasq config file have "dhcp-option-force=26,1454"

KoSuKe gravatar imageKoSuKe ( 2015-03-27 15:48:01 -0500 )edit

dhcp packets are very small, so when encapsulated they still would be much smaller than standard mtu

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-03-28 02:03:42 -0500 )edit

has your dnsmasq config any other additional things we don't know about?

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-03-28 02:20:20 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-26 10:28:32 -0500

Seen: 650 times

Last updated: Apr 07 '15