Ask Your Question
1

How to make devstack configuration persistent between reboots on Fedora 21?

asked 2015-03-25 06:49:56 -0500

That is question comes from recent thread
https://ask.openstack.org/en/question/59789/attempt-to-install-nova-docker-driver-on-fedora-21/ (https://ask.openstack.org/en/question...)
It appears that openvswitch module doesn't get loaded after cold restart and I have found fix for this

systemctl enable openvswitch

which brings OVS system back to life along with standard procedure of reassignment IP to br-ex
But , after that - running ./rejoin-stack.sh I found out that keystone daemons are dead.

edit retag flag offensive close merge delete

Comments

systemctl enable httpd in addition doesn't help as well. keystone daemons are in bad shape.
I can compare with similar picture on Ubuntu 14.04 box after ./rejoin-stack.sh

dbaxps gravatar imagedbaxps ( 2015-03-25 11:29:13 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-03-26 15:09:20 -0500

dbaxps gravatar image

updated 2015-03-26 15:26:55 -0500

To make devstack configuration persistent between reboots on Fedora 21
Status of following services must be :-

    systemctl enable rabbitmq-server
    systemctl enable openvswitch
    systemctl enable httpd
    systemctl enable mariadb
    systemctl enable  mysqld

File /etc/rc.d/rc.local should contain ( in my case ) :-

ip addr flush dev br-ex ;
ip addr add 192.168.10.15/24 dev br-ex ;
ip link set br-ex up ;
route add -net 10.254.1.0/24 gw 192.168.10.15 ;

System is supposed to be shutdown via :-

$sudo ./unstack.sh
edit flag offensive delete link more

Comments

Thank you for quick solution.

andrew.shvartz gravatar imageandrew.shvartz ( 2015-03-26 15:41:55 -0500 )edit

I've got several gcc warnings during driver build and a couple of additional modules fallen back to usual python. However, driver been built works fine. Due to some recent updates in your blog I completed set up relatively quick. Thanks again

andrew.shvartz gravatar imageandrew.shvartz ( 2015-03-27 05:31:50 -0500 )edit

I also have to notice that current version of python-six is 1.9 on f21, there is no need to install and reinstall via rawhide. What about python-pip , here you are correct.

andrew.shvartz gravatar imageandrew.shvartz ( 2015-03-27 05:37:16 -0500 )edit
1

answered 2015-03-26 11:26:16 -0500

I'd suggest working through this document:

https://opensource.ncsa.illinois.edu/...

The important point is to make sure that RabbitMQ is started and running before you run the rejoin-stack.sh command.

edit flag offensive delete link more

Comments

I've just tested your suggestion. I was able to start rabbitmq-server, however neutron-server failed to start on F21 via rejoin-stack.sh. Attempt to issue start neutron-server manually, I had prepared sample of command line saved, also failed due to failure connect to mysql database.

dbaxps gravatar imagedbaxps ( 2015-03-26 12:10:52 -0500 )edit

Once again I have this problem on F21. On Ubuntu 14.04.2 even rabbitmq-server is self started service and I just run ./rejoin-stack.sh

dbaxps gravatar imagedbaxps ( 2015-03-26 12:15:02 -0500 )edit

Thank you so much

dbaxps gravatar imagedbaxps ( 2015-03-26 12:20:06 -0500 )edit

Next reboot I woud test with :-

    systemctl enable rabbitmq-server
    systemctl enable openvswitch
    systemctl enable httpd
    systemctl enable mariadb
    systemctl enable  mysqld
dbaxps gravatar imagedbaxps ( 2015-03-26 13:15:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-25 06:49:56 -0500

Seen: 1,226 times

Last updated: Mar 26 '15