Ask Your Question
0

migrate instances with Ubuntu 14.04 from Havana to Juno

asked 2015-03-23 14:09:58 -0500

faelrba gravatar image

Hi all, I am trying to migrate VMs with Ubuntu 14.04 server from havana to Juno. I can migrate all my VMs with Ubuntu 12.04, but when I try to migrate the ones with 14.04 I got a message like "no bootable device" in the instance console in Juno. I've used the same method for both OSs: snapshot the source VM in Havana, upload the snapshot to Juno and launch instance from snapshot. Again, I can migrate instances with Ubuntu 12.04 but when I try to migrate the ones with 14.04 I got "no bootable device" error. Any idea?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-23 16:08:02 -0500

echiu gravatar image

This seems like it is related to the image itself, rather than the migration process. Please check the following in your Ubuntu 14.04 image: 1. are you booting from a volume? 2. if so, you may need to attach the volume in cinder before you boot the Nova instance.

If you can provide details from nova-conductor.log in /var/logs that would be helpful.

edit flag offensive delete link more

Comments

@echiu thanks for your answer. I agree that it's related to the image, but I can't find the exact reason for this error. For your questions: 1: My instance is not booting from any volume. 2: The logs from nova-conductor are empty, even if the debug flag set to true in nova.conf.

faelrba gravatar imagefaelrba ( 2015-03-24 08:56:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-23 14:09:58 -0500

Seen: 133 times

Last updated: Mar 23 '15