Ask Your Question
0

Error 404 when trying to monitor Vm's using Nagios on browser ?

asked 2015-03-23 10:24:10 -0500

HK gravatar image

I am using CentOs 7 and have installed openstack using Packstack.

Openstack by default installs Nagios :

  • To use Nagios, browse to http://172.16.32.101/nagios username: nagiosadmin, password: ac0d2 dca83e4* But when i try launching this on browser.. it gives error: 404 Not Found The requested URL /nagios was not found on this server.

Someone please help resolve this issue.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-23 12:10:40 -0500

Check if the nagios Alias and the ScriptAlias exist in your Apache configuration. You're probably looking for this file:

/etc/httpd/conf.d/nagios.conf

Don't forget to restart Apache to test - if that file's not there, your Nagios install isn't complete. If that file is there and has Alias entries in it for Nagios, check the Apache logs for more information.

edit flag offensive delete link more

Comments

yes... i do not have nagios.conf file. Can you please suggest in detail how i should install it.

HK gravatar imageHK ( 2015-03-23 23:53:06 -0500 )edit

By default, PackStack does not install Nagios. To install Nagios, you must set the CONFIG_NAGIOS_INSTALL parameter to y in the answer file or during the interactive set up.

tedlit gravatar imagetedlit ( 2015-03-24 11:52:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-23 10:24:10 -0500

Seen: 774 times

Last updated: Mar 23 '15