Ask Your Question
1

RDO quickstart "Juno" release guide for fedora 20

asked 2015-03-23 09:08:47 -0500

thewizardofOZ gravatar image

I successfuly installed OpenStack on one host machine, of course there was some errors, here is how I fix them.

First thing first: update kernel

yum -y install gcc kernel-headers kernel-devel

and fedora itself

sudo yum update -y

now you can check kernel version, it should be like this;

uname -r
3.18.9-100.fc20.x86_64

in case your system is running with NetworkManager, you need to disable it.

systemctl stop NetworkManager
systemctl disable NetworkManager
systemctl enable network

after this, you should check your connectivity, make sure you have internet access. In my scenario I had to add default gateway.

route add default gw YOUR.DEFAULT.GATEWAY

you have to take down all interfaces (but the one via you're connected to the machine) but I must say I didn't get the second code on the website so I fallow the commands below(I have only two interfaces):

ifdown em2

ifdown em1 && systemctl start network

To avoid this error message during the installation;

ERROR : Error appeared during Puppet run: 172.17.150.100_keystone.pp
Error: /Stage[main]/Apache::Service/Service[httpd]: Failed to call refresh: Could not start Service[httpd]: Execution of '/sbin/service httpd start' returned 1: Redirecting to /bin/systemctl start  httpd.service
You will find full trace in log /var/tmp/packstack/20150321-101313-Y4ltZn/manifests/172.17.150.100_keystone.pp.log

you should add https services manually sudo yum httpd -y and add Include conf.modules.d/*.conf on /etc/httpd/conf/httpd.conf file

Update your current packages:

sudo yum update -y

Setup the RDO repositories:

sudo yum install -y https://rdo.fedorapeople.org/rdo-release.rpm

again, if you get an error message like this during the installation,

Error: /Stage[main]/Neutron::Keystone::Auth/Keystone_service[neutron]: Could not evaluate: Execution of '/usr/bin/openstack service list --quiet --format csv --long --os-token 636c43645dbc442088a4862a9b1046f0 --os-url http://127.0.0.1:35357/v2.0/' returned 1: ERROR: openstack Internal Server Error (HTTP 500)

you should change SELINUX /etc/selinux/config file and make the line:

SELINUX=permissive

you have to

reboot

and finally

packstack --allinone

thats it.

enjoy your single node OpenStack!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-04-01 08:34:53 -0500

rbowen gravatar image

Thanks for this helpful walkthrough. I wonder if you might be willing to submit this as a new howto document for the http://rdoproject.org/ website?

edit flag offensive delete link more

Comments

Hi Rich;

I would like to help, just let me know what should I do.

thewizardofOZ gravatar imagethewizardofOZ ( 2016-04-01 09:45:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-23 09:08:47 -0500

Seen: 2,664 times

Last updated: Apr 01 '16