Ask Your Question
1

Does swift 1.0 supports object versioning ?

asked 2015-03-23 00:17:27 -0600

sumit gravatar image

updated 2015-03-23 08:19:13 -0600

rbowen gravatar image

I have installed swift 1.0 and have been using it for a long time. Now I want object versioning, so I want to know whether swift 1.0 supports object versioning on not.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-23 13:44:14 -0600

It doesn't appear so as it's not mentioned in the Swift API v1.0 docs http://developer.openstack.org/api-re...

edit flag offensive delete link more
0

answered 2015-03-23 17:36:55 -0600

echiu gravatar image

The API documentation is not complete, so you should verify this directly by checking in the configuration file.

Add object version /etc/swift/container-server/container-server.conf

To enable object versioning, the cloud provider sets the allow_versions option to TRUE in the container configuration file.

This feature has been in Swift since at least 2012, so there is a good chance it is in v1.

edit flag offensive delete link more
0

answered 2015-03-25 10:32:51 -0600

zaitcev gravatar image

If the question is about Swift releases, the 1.0 did not support object versions. The first release that did was 1.5.0, committed in June 2012. It was part of OpenStack Essex release.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-23 00:17:27 -0600

Seen: 130 times

Last updated: Mar 25 '15