Ask Your Question
0

Getting HTTPConnectionPool - Ceilometer [closed]

asked 2015-03-22 06:45:37 -0500

updated 2015-03-22 07:22:53 -0500

Hi All,

Please guide me to fix the below ceilometer issue. I am getting connection pool error however I configured my necessary details on compute node. Please find my error and configuration details and help me if anything I missed..

http://docs.openstack.org/juno/instal...

ceilometer meter-list
HTTPConnectionPool(host='192.168.2.61', port=8777): Max retries exceeded with url: /v2/meters (Caused by <class 'socket.error'>: [Errno 111] Connection refused)

mongo --host controller --eval ' db = db.getSiblingDB("ceilometer"); db.addUser({user: "ceilometer", pwd: "CEILOMETER_DBPASS", roles: [ "readWrite", "dbAdmin" ]})'

Service: metering
+-------------+----------------------------------+
|   Property  |              Value               |
+-------------+----------------------------------+
|   adminURL  |     http://192.168.2.61:8777     |
|      id     | 7cfc5cef508b446b87ebe9f915a69fab |
| internalURL |     http://192.168.2.61:8777     |
|  publicURL  |     http://192.168.2.61:8777     |
|    region   |            regionOne             |
+-------------+----------------------------------+

Controller Node
    /etc/ceilometer/ceilometer.conf
    [DEFAULT]
    rpc_backend = rabbit
    rabbit_host = 192.168.2.61
    rabbit_userid = ceilometer
    rabbit_password = ceilometer
    auth_strategy = keystone
    verbose = True
    [database]
    connection = mongodb://ceilometer:ceilometer@ceilometer:27017/ceilometer
    [keystone_authtoken]
    auth_uri = http://192.168.2.61:5000/v2.0
    identity_uri = http://192.168.2.61:35357
    admin_tenant_name = service
    admin_user = ceilometer
    admin_password = ceilometer
    [publisher]
    metering_secret = b4a4a608927fec762bcd
    [service_credentials]
    os_auth_url = http://192.168.2.61:5000/v2.0
    os_username = ceilometer
    os_tenant_name = service
    os_password = ceilometer


Compute Node:
/etc/ceilometer/ceilometer.conf
[DEFAULT]
rpc_backend = rabbit
rabbit_host = 192.168.2.61
rabbit_userid = ceilometer
rabbit_password = ceilometer
verbose = True
[keystone_authtoken]
auth_uri = http://192.168.2.61:5000/v2.0
identity_uri = http://192.168.2.61:35357
admin_tenant_name = service
admin_user = ceilometer
admin_password = ceilometer
[publisher]
metering_secret = b4a4a608927fec762bcd
[service_credentials]
os_auth_url = http://192.168.2.61:5000/v2.0
os_username = ceilometer
os_tenant_name = service
os_password = ceilometer
os_endpoint_type = internalURL
os_region_name = regionOne

/etc/nova/nova.conf
instance_usage_audit = True
instance_usage_audit_period = hour
notify_on_state_change = vm_and_task_state
notification_driver = messagingv2
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Pradipta_OS_M
close date 2015-03-22 07:39:12.690696

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-22 07:38:54 -0500

Did one small mistake.. Issue has fixed ..

connection = mongodb://ceilometer:ceilometer@192.168.2.61:27017/ceilometer
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-22 06:45:37 -0500

Seen: 985 times

Last updated: Mar 22 '15