Ask Your Question
0

No valid hosts ??

asked 2015-03-19 11:00:58 -0500

adabney15 gravatar image

updated 2015-03-19 11:40:56 -0500

bishoy gravatar image

Hi , I have a Juno setup running on Ubuntu 14.10, when i attempt to spawn a instance the error comes back as no valid host..i have searched countless threads and have none of the suggestions have worked. Your help would be appreciated.. Here is the conductor log

2015-03-19 10:32:05.673 3867 INFO oslo.messaging._drivers.impl_rabbit [req-1b8707db-a258-441d-9ecc-1d36259c6834 ] Connecting to AMQP server on controller:5672
2015-03-19 10:32:05.687 3867 INFO oslo.messaging._drivers.impl_rabbit [req-1b8707db-a258-441d-9ecc-1d36259c6834 ] Connected to AMQP server on controller:5672
2015-03-19 10:35:30.942 3870 ERROR nova.scheduler.utils [req-1b8707db-a258-441d-9ecc-1d36259c6834 None] [instance: fb74669b-8790-4e1c-a88c-f7d286f3c312] Error from last host: compute (node compute): [u'Traceback (most recent call last):\n', u'  File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 2039, in _do_build_and_run_instance\n    filter_properties)\n', u'  File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 2170, in _build_and_run_instance\n    instance_uuid=instance.uuid, reason=six.text_type(e))\n', u'RescheduledException: Build of instance fb74669b-8790-4e1c-a88c-f7d286f3c312 was re-scheduled: Unexpected vif_type=binding_failed\n']
2015-03-19 10:35:30.945 3870 INFO oslo.messaging._drivers.impl_rabbit [req-1b8707db-a258-441d-9ecc-1d36259c6834 ] Connecting to AMQP server on controller:5672
2015-03-19 10:35:30.958 3870 INFO oslo.messaging._drivers.impl_rabbit [req-1b8707db-a258-441d-9ecc-1d36259c6834 ] Connected to AMQP server on controller:5672
2015-03-19 10:35:30.980 3870 WARNING nova.scheduler.driver [req-1b8707db-a258-441d-9ecc-1d36259c6834 None] [instance: fb74669b-8790-4e1c-a88c-f7d286f3c312] NoValidHost exception with message: 'No valid host was found.'
2015-03-19 10:35:30.981 3870 WARNING nova.scheduler.driver [req-1b8707db-a258-441d-9ecc-1d36259c6834 None] [instance: fb74669b-8790-4e1c-a88c-f7d286f3c312] Setting instance to ERROR state.
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2015-03-19 11:45:49 -0500

bishoy gravatar image

Make sure your bridge on bot the compute and network node are correctly configured. All the neutron services are running correctly on all nodes and all agents are up and neutron are configured with rabbit. Also check nova.conf for accessing neutron and virt_type. It will be nice if you share :

neutron agent-list 
/var/log/neutron/neutron-server(on controller) neutron-l2 agent log(on network node and compute node)
edit flag offensive delete link more

Comments

I dont have a l2-agent..but i have a l3 agent only on the network node.. it just says sigterm exiting ...

adabney15 gravatar imageadabney15 ( 2015-03-20 17:01:41 -0500 )edit

I would recommend to check the manuals how to install the L2 agen and configure either ways using OVS or linux bridge

bishoy gravatar imagebishoy ( 2015-03-23 05:11:14 -0500 )edit
0

answered 2015-03-19 11:27:45 -0500

Remko Duppen gravatar image

updated 2015-03-19 11:28:31 -0500

I would say that "Unexpected vif_type=binding_failed" points to a networking misconfiguration. So you should check your neutron configuration and log files first

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-19 10:38:35 -0500

Seen: 357 times

Last updated: Mar 19 '15