Ask Your Question
0

error: openstack proxy authentication required (HTTP 407)

asked 2015-03-17 06:14:03 -0500

NC gravatar image

While installing the devstack, on running ./stack.sh command, the installation is going well till creation of keystone accounts. I am getting the HTTP 407 error at the creation, admin_tenant, admin_role step. I have tried changing my proxy setting on ubuntu server 14.04 but nothing helped out.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-17 08:15:02 -0500

bobyakov gravatar image

Did keystone DB get created successfully? Did the endpoints get created?

edit flag offensive delete link more

Comments

yes the DB and endpoints got created. There error arrives at the line of openstack project create admin and subsequently with ADMIN_TENANT and ADMIN_ROLE. I have also noticed that after line: echo "waiting for keystone to start...", timeout 60 line arrives.

NC gravatar imageNC ( 2015-03-18 00:13:27 -0500 )edit
0

answered 2015-04-01 19:36:32 -0500

Bang gravatar image

Hi , I am get in same Problem . help please !

root@controler:~# keystone tenant-create --name=admin --description="Admin Tenant" Proxy Authentication Required (HTTP 407)

root@controler:~# env | grep http OS_SERVICE_ENDPOINT=http://localhost:35357/v2.0 http_proxy=http://username:password@proxyhost:8080/ https_proxy=http://username:password@proxyhost:8080/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-03-17 06:14:03 -0500

Seen: 574 times

Last updated: Mar 17 '15