Ask Your Question
0

Can't Populate the database su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \ --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade juno" neutron"

asked 2015-03-17 05:42:44 -0500

Vatsal gravatar image

updated 2015-03-17 10:22:47 -0500

larsks gravatar image

[root@controller ~]# su -s /bin/sh -c "neutron-db-manage --config-file /etc/neutron/neutron.conf \ --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade juno" neutron

[...]
  File "/usr/lib/python2.7/site-packages/oslo/config/cfg.py", line 1104, in __call__
    ConfigParser._parse_file(values, namespace)

  File "/usr/lib/python2.7/site-packages/oslo/config/cfg.py", line 1307, in _parse_file
    raise ConfigFileParseError(pe.filename, str(pe))
oslo.config.cfg.ConfigFileParseError: Failed to parse /etc/neutron/neutron.conf: at /etc/neutron/neutron.conf:80, Unexpected continuation line: ' auth_strategy = keystone'

Here Are The Configured Lines In /etc/neutron/neutron.conf

[DEFAULT]
 auth_strategy = keystone
notify_nova_on_port_status_changes = true
notify_nova_on_port_data_changes = true
nova_url = http://controller:8774/v2
nova_region_name = regionOne
nova_admin_username = nova
nova_admin_tenant_id = 17d8100fe75b4f8fa2ea08b74a10f632
nova_admin_password = redhat
nova_admin_auth_url = http://controller:35357/v2.0
rabbit_host=controller
rabbit_password=redhat
rpc_backend=rabbit
[matchmaker_redis]
[matchmaker_ring]
[quotas]
[agent]
[keystone_authtoken]
auth_uri = http://controller:5000/v2.0
identity_uri = http://controller:35357
admin_tenant_name = service
admin_user = neutron
admin_password = redhat
[database]
connection = mysql://neutron:redhat@controller/neutron
[service_providers]
service_provider=LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default
service_provider=VPN:openswan:neutron.services.vpn.service_drivers.ipsec.IPsecVPNDriver:default
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-03-17 10:25:24 -0500

larsks gravatar image

The error seems pretty clear:

oslo.config.cfg.ConfigFileParseError: Failed to parse /etc/neutron/neutron.conf: at /etc/neutron/neutron.conf:80, Unexpected continuation line: ' auth_strategy = keystone'

You've removed a bunch of comments from your file so there's no way to tell what actually on line 80, but I'm guessing the fact that you have auth_strategy indended with whitespace is causing your problem. Try changing:

[DEFAULT]
 auth_strategy = keystone

To:

[DEFAULT]
auth_strategy = keystone
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-17 05:42:44 -0500

Seen: 1,006 times

Last updated: Mar 17 '15