Ask Your Question
1

Devstack installation error: Gateway Timeout

asked 2015-03-17 03:08:39 -0500

CloudIsMyLife gravatar image

updated 2015-03-17 13:23:50 -0500

smaffulli gravatar image

My all the installations are working fine but When creating the users I am getting the following errors:

openstack project create admin --or-show -f value -c id
ERROR: openstack Gateway Timeout (HTTP 504)
++ local project_id=
++ echo
+ local admin_tenant=
++ get_or_create_user admin srm
++ [[ ! -z '' ]]
++ local email=
++ local os_cmd=openstack
++ local domain=
++ [[ ! -z '' ]]
+++ openstack user create admin --password srm --or-show -f value -c id
ERROR: openstack Gateway Timeout (HTTP 504)
++ local user_id=
++ echo
+ local admin_user=
++ get_or_create_role admin
+++ openstack role create admin --or-show -f value -c id
ERROR: openstack Gateway Timeout (HTTP 504)
edit retag flag offensive close merge delete

Comments

try checking logs and edit the question to add more details as you go on debugging this timeout

smaffulli gravatar imagesmaffulli ( 2015-03-17 13:24:38 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-17 13:09:09 -0500

dbaxps gravatar image

I believe, that install described here https://fosskb.wordpress.com/2014/10/...
will finally satisfy you much more then devstack stuff. What is the most important will give you much better understanding what services and how are installed during Juno AIO setup on Ubuntu 14.04.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-17 03:08:39 -0500

Seen: 761 times

Last updated: Mar 17 '15