Ask Your Question
0

Unable to get DHCP lease in Juno

asked 2015-03-16 20:14:25 -0500

beinghuman gravatar image

Hi I followed http://docs.openstack.org/juno/instal... guide to build Openstack with 3 nodes(Compute, controller & neutron). I was able to get everything up but finally when i launch any instance, it is not getting any IP. I see,

Starting network...

udhcpc (v1.20.1) started

Sending discover...

Sending discover...

Sending discover...

No lease, failing

But it fails to get an IP. Can someone shed some light into this to help me fix this please.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-17 18:17:53 -0500

beinghuman gravatar image

Hi everyone. I tried the above but didnt help so started from scratch and built a new compute node and its all working fine now :) I am comparing the logs and config to find out why it didnt work previously. I will update it here if i find the culprit. thanks for your help!

edit flag offensive delete link more

Comments

I would be curious :)

GLaupre gravatar imageGLaupre ( 2015-03-17 19:40:46 -0500 )edit
0

answered 2015-03-16 21:08:48 -0500

GLaupre gravatar image

updated 2015-03-16 21:11:04 -0500

Hello,

Take a look at my question there. You should find some directions. Big lines were to start the dnsmasq as root. (I thought if was corrected by the time..)

Hope it helps, cheers

edit flag offensive delete link more

Comments

This bug was fixed a while ago. Please, do

1. Activate dnsmasq.log
2. Post `ovs-vsctl show` on network node.
dbaxps gravatar imagedbaxps ( 2015-03-17 02:46:56 -0500 )edit

Add to dhcp_agent.ini line:-

dnsmasq_config_file = /etc/neutron/dnsmasq.conf
Create under /etc/neutron    dnsmasq.conf
log-facility = /var/log/neutron/dnsmasq.log
log-dhcp
Restart neutron-dhcp-agent
dbaxps gravatar imagedbaxps ( 2015-03-17 02:50:38 -0500 )edit

Possibly firewall on neutron. Also, you can watch to see if you are receiving the request by looking at /var/log/messages while creating an instance. If you dont see any dhcp request then it means you need to check your tenant network tunnel if properly configured.

Check the router 'ip netns'

foster gravatar imagefoster ( 2015-03-17 04:34:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-16 20:14:25 -0500

Seen: 1,990 times

Last updated: Mar 17 '15