linuxbridge plugin vif bind failed

asked 2015-03-16 10:26:36 -0500

azriel gravatar image

Hi,

  • I'm using Ubuntu 14.04 with Juno all-in-one installation.
  • I'm having trouble to bind tenant network (type vlan) to a router (which is connected to a flat network).
  • I'm using the linuxbridge agent with ml2 plugin, with flat network configuration for my external traffic (which is provisioned ok) and tenant network types is set to vlan where I get :
  • "vif_type: binding_failed"
  • "In _notify_port_updated(), no bound segment for port"
  • "not defined on plugin"

logs - http://paste.openstack.org/show/192647/

ml2conf - http://paste.openstack.org/show/192584/

neutron conf - http://paste.openstack.org/show/192649/

mysql DB - http://paste.openstack.org/show/192607/

ps awux | grep neutron (output) - http://paste.openstack.org/show/192650/

nova.conf - http://paste.openstack.org/show/192652/

edit retag flag offensive close merge delete

Comments

since it's type vlan, i presume it's from physnet3 which is not in physical_interface_mappings - that would it explain why the binding failed

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-03-18 17:42:33 -0500 )edit

Can't I have my physical interface mapping as flat and internal networks as type vlan?

azriel gravatar imageazriel ( 2015-03-19 01:54:25 -0500 )edit

type vlan provider neutron networks are backed by physical networks via bridges to switch trunk ports. Since you have an all-in-one, type local will do for internal networks.

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-03-19 02:26:22 -0500 )edit

setting type local won't do vlan encapsulation? can you please elaborate on type local, and what will be my external NIC? flat?

azriel gravatar imageazriel ( 2015-03-19 04:22:41 -0500 )edit

yes - you can use type local for the internals and flat for the external

darragh-oreilly gravatar imagedarragh-oreilly ( 2015-03-19 13:43:03 -0500 )edit