Ask Your Question
0

Failed to launch instance "test": Please try again later [Error: No valid host was found. ]

asked 2015-03-15 14:52:10 -0500

aupres gravatar image

I try to make instance on openstack private cloud web UI. But it fails.The error code is

Failed to launch instance "test": Please try again later [Error: No valid host was found. ].

In /var/log/nova/nova-scheduler.log these errors are shown.

2015-03-16 03:32:26.824 1705 INFO oslo.messaging._drivers.impl_rabbit [req-50543fb4-b607-4b50-9578-6435600d516b ] Delaying reconnect for 1.0 seconds...
2015-03-16 03:32:27.825 1705 INFO oslo.messaging._drivers.impl_rabbit [req-50543fb4-b607-4b50-9578-6435600d516b ] Connecting to AMQP server on privatecloud:5672
2015-03-16 03:32:27.830 1705 ERROR oslo.messaging._drivers.impl_rabbit [req-50543fb4-b607-4b50-9578-6435600d516b ] AMQP server on privatecloud:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 30 seconds.

I think my configuration is something wrong. What do i have to do? Your advice will be deeply appreciated. Thanks

edit retag flag offensive close merge delete

Comments

Check password for AMQP in your nova config, also check if there is a problem with the connection(firewall blocking connections, selinux, etc)

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-03-15 16:19:42 -0500 )edit

Pls, inform me of the property names of AMQP in my nova config which I have to check. I am afraid there are so property names in vova.conf file.

aupres gravatar imageaupres ( 2015-03-16 14:45:50 -0500 )edit

[DEFAULT] ... rpc_backend = rabbit rabbit_host = controller rabbit_password = RABBIT_PASS If you didn't changed the password when installed rabbitmq use "guest" as default password, check nova.conf in controller and compute node.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2015-03-16 15:43:31 -0500 )edit

I found this ref. "For RabbitMQ version 3.3.0 or newer, you must enable remote access for the guest account" so I made file like below

#vi /etc/rabbitmq/rabbitmq.config

[{rabbit, [{loopback_users, []}]}].

But the same error is thrown. I am using CentOS 7. anything i have to do ?

aupres gravatar imageaupres ( 2015-03-21 16:48:05 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-21 18:39:26 -0500

aupres gravatar image

updated 2015-03-21 18:40:16 -0500

I solved it. I modified /etc/rabbitmq/rabbitmq.config like this ;

[
    {mnesia, [{dump_log_write_threshold, 1000}]},
    {rabbit, [{tcp_listeners, [5672]}]}
  ].

Then it is connected.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-15 14:52:10 -0500

Seen: 994 times

Last updated: Mar 15 '15