Ask Your Question
0

demo instances fail to build on Ubuntu 14.04.2/Juno

asked 2015-03-14 19:28:58 -0500

MrZog gravatar image

updated 2015-03-16 13:42:21 -0500

rbowen gravatar image

I'm following http://docs.openstack.org/juno/instal... . I have a compute node, a neutron network node and a controller. I noticed that when I've sourced demo-openrc.sh I can't see the dotted quad for the external network: http://pastie.org/10026701 <-- (If you click the arrows in the top-right corner the formatting gets fixed.)

I set up the external network thus:

neutron subnet-create ext-net --name ext-subnet --allocation-pool start=192.168.10.21,end=192.168.10.44 --disable-dhcp --disable-dhcp --gateway 192.168.10.1 192.168.10.0/24

And the tenant net like so:

neutron subnet-create demo-net0 --name demo-subnet0 --gateway 192.168.1.1 192.168.1.0/24

So far the only error I see is in nova-api.log.

2015-03-14 23:57:35.359 6056 INFO nova.api.openstack.wsgi [req-a1c12d79-a661-4e89-8d56-914fd04ad725 None] HTTP exception thrown: The resource could not be found.
edit retag flag offensive close merge delete

Comments

MrZog gravatar imageMrZog ( 2015-03-16 09:56:45 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-16 20:05:52 -0500

beinghuman gravatar image

Hi, I had the same issue.You need to add,

vif_plugging_is_fatal = False vif_plugging_timeout = 0

in /etc/nova/nova.conf This should resolve it.

edit flag offensive delete link more

Comments

Thanks. I tried adding those two lines to the DEFAULT section of my nova.conf file on the controller machine. The build is stuck in Task State 'spawning'.

MrZog gravatar imageMrZog ( 2015-03-16 21:07:37 -0500 )edit

Also tried them in the [neutron] section. Did not work. Here is my nova.conf http://paste.openstack.org/show/192789/

MrZog gravatar imageMrZog ( 2015-03-16 22:47:03 -0500 )edit

I ran 'ovs-vsctl add-port br-ex' then 'ovs-vsctl add-port br-ex eth0' where eth0 is my net node's management interface. Then I restarted all my neutron services and there was no eth0-br.

MrZog gravatar imageMrZog ( 2015-03-18 14:33:42 -0500 )edit

My network node's ifconfig. http://paste.openstack.org/show/193274/

MrZog gravatar imageMrZog ( 2015-03-18 16:52:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-14 19:28:58 -0500

Seen: 190 times

Last updated: Mar 16 '15