Ask Your Question
0

Don't log with new user centos 7.0 instance

asked 2015-03-13 17:06:34 -0500

cesarufmt gravatar image

I use devstack single machine.

I log into machine with keys (machine.pem). But I created a new user and insert that user in /etc/sudoers file. When I make logout and I try log again with new user CentOS 7 show me:

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

The mistake appears with or wihout use the keys.

I did disabled selinux.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-07-03 16:14:11 -0500

I just hit this, same error. Check the permissions for files in ~/.ssh for the user you just created on the VM instance, mine had some group, other reads that should not have been there. I fixed the permissions and login works now.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-13 17:06:34 -0500

Seen: 155 times

Last updated: Mar 13 '15