Ask Your Question
0

heat engine failed to start

asked 2015-03-12 05:23:23 -0500

GreenyZed gravatar image

Hi Ask Openstack,

I test Openstack solution on Debian Wheezy nodes. I carefully followed the installation guide for Wheezy.

I try to start heat-engine on my controller node with

heat-engine --debug

I encounter this error :

2015-03-12 08:52:59.347 20188 CRITICAL heat.engine [-] Could not load AWSTemplateFormatVersion.2010-09-09: (sqlalchemy-migrate 0.9.5 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('sqlalchemy-migrate==0.9.1'))
ERROR: No template format plugins registered

I thought it was a problem with sqlalchemy version so I remove and reinstall it :

pip uninstall sqlalchemy && pip install sqlalchemy==0.9.1

And this time :

 ImportError: Unable to import backend 'sqlalchemy'

So I upgrade to the 0.9.5 version of sqlalchemy and go back to the first error.

If someone can help me to solve this issue please let me now.

Thanks. Charles

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-03-12 15:31:10 -0500

GreenyZed gravatar image

I found a solution:

The issue was on some python package version.

I start with :

pip install sqlalchemy-migrate==0.9.1

And then heat-engine --debug show this error :

2015-03-12 20:55:53.314 30658 CRITICAL heat.engine [-] Could not load AWSTemplateFormatVersion.2010-09-09: (oslo.db 1.7.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('oslo.db>=1.0.0,<1.1'))

After some tries on

pip install oslo.db==1.0.X

I found that only version 1.0.3 match requirement for sqlalchemy.

pip install oslo.db==1.0.3

After this heat-engine --debug complains about :

2015-03-12 21:05:49.128 30938 CRITICAL heat.engine [-] Could not load AWSTemplateFormatVersion.2010-09-09: (eventlet 0.17.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('eventlet>=0.15.1,<0.16.0'))

So

pip install eventlet 0.15.1

But I still got an error : (

2015-03-12 21:06:28.185 30968 CRITICAL heat.engine [-] Could not load AWSTemplateFormatVersion.2010-09-09: (eventlet 0.15.1 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('eventlet>=0.15.2'))

So pip install eventlet 0.15.2`

And now in heat engine log file

/var/log/heat/heat-engine.log

2015-03-12 21:07:35.269 31044 INFO oslo.messaging._drivers.impl_rabbit [-] Connected to AMQP server

Strange dependencies I think, but problem solved : )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-12 04:38:35 -0500

Seen: 449 times

Last updated: Mar 12 '15