Ask Your Question
0

Ceilometre Issue

asked 2015-03-11 15:28:11 -0500

felix001 gravatar image

updated 2015-03-29 15:53:02 -0500

When installing devstack with Icehouse. The install is failing on ceilometer due to the following. Ive tried to reinstall ceilometer to no joy. Any ideas ?

2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/usr/local/bin/ceilometer-api", line 10, in <module>
2015-03-11 20:19:41.627 31263 TRACE ceilometer     sys.exit(api())
2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/opt/stack/ceilometer/ceilometer/cli.py", line 97, in api
2015-03-11 20:19:41.627 31263 TRACE ceilometer     srv = app.build_server()
2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/opt/stack/ceilometer/ceilometer/api/app.py", line 126, in build_server
2015-03-11 20:19:41.627 31263 TRACE ceilometer     root = VersionSelectorApplication()
2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/opt/stack/ceilometer/ceilometer/api/app.py", line 96, in __init__
2015-03-11 20:19:41.627 31263 TRACE ceilometer     self.v1 = v1app.make_app(cfg.CONF, enable_acl=pc.app.enable_acl)
2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/opt/stack/ceilometer/ceilometer/api/v1/app.py", line 61, in make_app
2015-03-11 20:19:41.627 31263 TRACE ceilometer     app.wsgi_app = acl.install(app.wsgi_app, conf)
2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/opt/stack/ceilometer/ceilometer/api/acl.py", line 44, in install
2015-03-11 20:19:41.627 31263 TRACE ceilometer     conf=dict(conf.get(OPT_GROUP_NAME)))
2015-03-11 20:19:41.627 31263 TRACE ceilometer   File "/usr/local/lib/python2.7/dist-packages/keystoneclient/middleware/auth_token.py", line 591, in __init__
2015-03-11 20:19:41.627 31263 TRACE ceilometer     seconds=self._conf_get('revocation_cache_time'))
2015-03-11 20:19:41.627 31263 TRACE ceilometer TypeError: unsupported type for timedelta seconds component: str
2015-03-11 20:19:41.627 31263 TRACE ceilometer

My ceilometer.conf is

root@openstack-lab:~# cat /etc/ceilometer/ceilometer.conf

[DEFAULT]
os_tenant_name = service
os_password = icehouse
os_username = ceilometer
policy_file = /etc/ceilometer/policy.json
debug = True
verbose = True
notification_topics = notifications
rabbit_password = icehouse
rabbit_hosts = 134.213.x.x
rpc_backend = ceilometer.openstack.common.rpc.impl_kombu
revocation_cache_time = 1000


[keystone_authtoken]
signing_dir = /var/cache/ceilometer
admin_tenant_name = service
admin_password = icehouse
admin_user = ceilometer
auth_protocol = http
auth_port = 35357
auth_host = 134.213.x.x

[database]
connection = mysql://root:icehouse@127.0.0.1/ceilometer?charset=utf8
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-11 20:19:43 -0500

In /etc/ceilometer/ceilometer.conf you are have this option revocation_cache_time but you have no value set. Just comments this out and restart ceilometer.

edit flag offensive delete link more

Comments

Within my ceilometer.conf file I have no line referencing the option revocation_cache_time. Any other options to get this working ?

felix001 gravatar imagefelix001 ( 2015-03-13 08:59:37 -0500 )edit

Can you paste your ceilometer.conf please. If

sfcloudman gravatar imagesfcloudman ( 2015-03-13 17:05:39 -0500 )edit

Ive added my ceilometer.conf to the original question ....

felix001 gravatar imagefelix001 ( 2015-03-29 15:53:52 -0500 )edit

Under keystone_authtoken add:

revocation_cache_time=30

Restart ceilometers services

sfcloudman gravatar imagesfcloudman ( 2015-03-29 20:13:42 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-11 15:28:11 -0500

Seen: 70 times

Last updated: Mar 29 '15