Ask Your Question
0

git clone hangs in checking username

asked 2015-03-09 13:18:58 -0500

Pradip gravatar image

Hello,

I want to use all services from devstack, but only cinder from a private depo. So I modified the stackrc file herein:

PRIVATE_GIT_BASE=https://github.com/private-openstack-dev
CINDER_REPO=${CINDER_REPO:-${PRIVATE_GIT_BASE}/cinder.git}
CINDER_BRANCH=${CINDER_BRANCH:-master}

The problem is: during clone in stack.sh, it is asking for username. I am giving the user-name. Then it is hanging forever. The password prompt is not coming.

2015-03-09 18:09:32.356 | + timeout=0
2015-03-09 18:09:32.356 | + timeout -s SIGINT 0 git clone https://github.com/private-openstack-dev/cinder.git /opt/stack/cinder
2015-03-09 18:09:32.359 | Cloning into '/opt/stack/cinder'...
Username for 'https://github.com': my-user-name
.......... hangs ..........

Any idea how to tackle this would be of great help.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-09 15:49:39 -0500

My suspicion would be a connectivity issue between you and github. Can you connect to git directly outside the script - ie, does the 'git clone' work manually? Can you ping github.com / connect to it on port 443?

edit flag offensive delete link more

Comments

Yeah! the normal thing works (I mean the manual stuff). What else should I test?

Pradip gravatar imagePradip ( 2015-03-09 23:01:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-09 13:18:58 -0500

Seen: 156 times

Last updated: Mar 09 '15