Ask Your Question
0

Openstack live migration ssh issue

asked 2015-03-09 01:15:38 -0500

Neetz gravatar image

Hey , I'm trying to live migrate an instance . I have referred many documentations about configuring nova and other dependenices, I'm currently stuck with this error .

Warning: Permanently added '10.10.126.63' (ECDSA) to the list of known hosts. Permission denied, please try again. Permission denied, please try again. Permission denied (publickey,password).: Connection reset by peer

It seems like a ssh issue , I'm stuck here for a week now , I'm doing a passwordless authentication and I have set up the keys perfectly, and before migratng i check each node is able to login without password by entering into ssh debug mode

ssh -v user@ip

Also , my ssh configuratons are set like

Host * StrictHostKeyChecking no

UserKnownHostsFile /dev/null

I don't know I'm still having the error which I mentioned :/ , kindly help :)

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-09 02:17:32 -0500

foster gravatar image

Live migration should have a shared file-system between the compute nodes you are trying to migrate between.

edit flag offensive delete link more

Comments

Yes I know it;s necessary , But this doesn't address the question ? , I think this is more of a ssh issue right now :/

Neetz gravatar imageNeetz ( 2015-03-09 02:25:45 -0500 )edit
1

i have the same setup and i don't have this problem when migrating instances between compute nodes. I also didn't have to change my settings for sshd. If you think its a problem with ssh try verifying your permissions on ~/.ssh. Problem could be that you have /dev/null instead of a file.

foster gravatar imagefoster ( 2015-03-09 02:45:35 -0500 )edit

@foser , I don't think it's a problem with live migration since I just try to migrate using virsh migrate , i get the same error , permission deined ! yes I also looked on the permissions of ssh it is 700 , and author_keys is 600 , I have checked that too before :/

Neetz gravatar imageNeetz ( 2015-03-09 02:50:45 -0500 )edit

Just to be clear..you are talking about 2 different issues. 1. is live migration which happens at the compute node (which requires shared filesytem). 2. is ssh access to the instance with passwordless ssh.

You need to solve the first problem in order to move forward with the second problem.

foster gravatar imagefoster ( 2015-03-09 02:56:13 -0500 )edit

I think I don't have any problems with the first issue , I have properly configured the file system part , the problem s the 2nd part :/

Neetz gravatar imageNeetz ( 2015-03-09 03:04:07 -0500 )edit
0

answered 2015-03-09 04:57:19 -0500

schegi gravatar image

Just to make it clear, you need to have password-less ssh configured between the nodes for the 'nova' user.

edit flag offensive delete link more

Comments

Hey even without with nova or openstack , like i tried without openstack , just migrating with virsh creating a VM on a local machine and migrating with virsh- migrate command , i get the same error, seems like a libvirt or ssh issue

Neetz gravatar imageNeetz ( 2015-03-10 01:54:27 -0500 )edit

Make sure that you copy the public key of both sides in the authorized hosts file. make sure that both users have passwordless ssh on the machines. Make sure you have the correct permissions and ownership of the folders that has the machines (/var/lib/libvirt, /varlib/nova). enable login for nova

bishoy gravatar imagebishoy ( 2015-03-10 06:52:10 -0500 )edit

@bishoy , Thanks for the reply,Yes i have setup passwordless authentication for both the systems and also root and user are passwordlesss,and I am able to login without password.but i don't get why do I have to enable nova here ? the instance here I created is local and openstack is not installed

Neetz gravatar imageNeetz ( 2015-03-10 07:03:42 -0500 )edit
0

answered 2015-03-09 10:52:59 -0500

bishoy gravatar image

Please make sure that the host and destination folders have the same permissions and ownership(nova). Enable the nova user to be be a login user as it's not enough to just save the keys in both destination and source.

edit flag offensive delete link more

Comments

@bishoy , Hey even without with nova or openstack , like i tried without openstack , just migrating with virsh creating a VM on a local machine and migrating with virsh- migrate command , i get the same error, seems like a libvirt or ssh issue

Neetz gravatar imageNeetz ( 2015-03-10 02:26:04 -0500 )edit

I mean enable nova in case of Openstack instance migration. Please make sure the permissions of the ll /var/lib/libvirt/qemu/ and ownership is something similar to that.

root@Bishoy:~# ll /var/lib/libvirt/qemu/ -d
drwxr-x--- 5 libvirt-qemu kvm 4096 mrt  2 17:02 /var/lib/libvirt/qemu//
bishoy gravatar imagebishoy ( 2015-03-10 08:07:10 -0500 )edit

Note the users in my last comment.

bishoy gravatar imagebishoy ( 2015-03-10 08:07:34 -0500 )edit

In case of centos

[root@openstack2 ~]# ll /var/lib/libvirt/qemu/ -d
drwxr-x---. 6 qemu qemu 4096 Feb 13 05:39 /var/lib/libvirt/qemu/
bishoy gravatar imagebishoy ( 2015-03-10 08:10:08 -0500 )edit

@bishoy , I have a ubuntu 14.04

I got the following when i did this root@celestial10:~# ll /var/lib/libvirt/qemu/ -d drwxr-x--- 5 libvirt-qemu kvm 4096 Mar 10 18:56 /var/lib/libvirt/qemu//

it's the same , still doesn't migrate :/

Neetz gravatar imageNeetz ( 2015-03-10 08:40:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-09 01:15:38 -0500

Seen: 1,087 times

Last updated: Mar 09 '15