Ask Your Question
0

instack-install-undercloud fails with glance: error: unrecognized arguments: --public

asked 2015-03-07 16:42:20 -0500

edwberger gravatar image

updated 2015-03-09 11:04:17 -0500

rbowen gravatar image

I'm trying to build a virtual openstack test platform using the directions at https://openstack.redhat.com/Deployin... and https://openstack.redhat.com/Deployin... using CentOS 7 or Fedora 21 on the base machine, and defining F20 and exporting NODE_DIST="fedora" , but the instack-install-undercloud command fails with..

+ glance image-create --name bm-deploy-kernel --public --disk-format aki
usage: glance [--version] [-d] [-v] [--get-schema] [--timeout TIMEOUT]
glance: error: unrecognized arguments: --public

Is this a known issue with a workaround or should I just try again with F20 on the base KVM server?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-09 11:50:37 -0500

bnemec gravatar image

Are you sure it's instack-install-undercloud that's failing? I believe that call actually happens in instack-prepare-for-overcloud: https://github.com/rdo-management/instack-undercloud/blob/stable/juno/scripts/instack-prepare-for-overcloud#L48 (https://github.com/rdo-management/ins...)

The workaround is to edit /usr/bin/instack-prepare-for-overcloud and change "--public" to "--is-public True". Note that there are actually 4 instances of --public in that file, and they will all need to be changed.

edit flag offensive delete link more
0

answered 2015-06-22 16:04:13 -0500

Napo Mokoetle gravatar image

Make sure you source the admin environment after adding glance version 2 ( export OS_IMAGE_API_VERSION=2 ) to your environment script. e.g.

root@ts036953:/home/pssuser# source admin-openrc.sh

edit flag offensive delete link more
0

answered 2015-03-09 12:20:21 -0500

larsks gravatar image

The --public flag was recently removed from the glance command line client; the equivalent is --is-public true. I believe that fixes for this already exist in Instack, but they may not have showed up in a release yet.

You can fix the script manually by simply replacing the --public flag.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-07 16:42:20 -0500

Seen: 2,997 times

Last updated: Jun 22 '15