Ask Your Question
0

Why can't cinder-scheduler authenticate to rabbitmq?

asked 2015-03-04 16:10:13 -0500

MrZog gravatar image

While setting up an iSCSI host (using http://docs.openstack.org/juno/install-guide/install/apt/content/cinder-verify.html (http://docs.openstack.org/juno/instal...) ) I discovered that cinder-scheduler is not running on my controller node. So I tailed the /var/log/cinder/cinder-scheduler log on the controller and saw,

2015-03-04 22:07:18.104 17613 INFO oslo.messaging._drivers.impl_rabbit [req-d76e8a3c-4cac-4711-81f4-8f7a93a095e4 - - - - -] Delaying reconnect for 1.0 seconds... 2015-03-04 22:07:19.106 17613 INFO oslo.messaging._drivers.impl_rabbit [req-d76e8a3c-4cac-4711-81f4-8f7a93a095e4 - - - - -] Connecting to AMQP server on localhost:5672 2015-03-04 22:07:22.121 17613 ERROR oslo.messaging._drivers.impl_rabbit [req-d76e8a3c-4cac-4711-81f4-8f7a93a095e4 - - - - -] AMQP server localhost:5672 closed the connection. Check login credentials: Socket closed

Also, my /etc/rabbit directory is completely empty. I have reset the rabbitmq guest account password to what I know is correct and other services are able to authenticate using these credentials.

edit retag flag offensive close merge delete

Comments

I reinstalled rabbitmq and now the cinder-scheduler can connect to rabbitmq @127.0.0.1 but cinder-volume is not able authenticate from the foreign block service node.

MrZog gravatar imageMrZog ( 2015-03-05 12:45:58 -0500 )edit

since you changed the password did you update all your conf files that use the rabbit password? If you run

grep -i rabbit /etc/cinder/cinder.conf  | grep -v ^#

does this reflect the same password you changed it to?

omar-munoz gravatar imageomar-munoz ( 2015-03-06 17:33:25 -0500 )edit

I had misconfigured my cinder.conf. The rabbit credentials were not in the [DEFAULT] section.

MrZog gravatar imageMrZog ( 2015-03-10 16:24:01 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-06 18:44:59 -0500

MrZog gravatar image

Yes. I have the password configured for guest properly. I just enabled the rabbitmq web interface and logged in as the guest user so I know the account works.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-04 16:10:13 -0500

Seen: 424 times

Last updated: Mar 06 '15