Ask Your Question
2

Error deploying VMs in Havana "Timeout while waiting on RPC response"

asked 2013-10-23 13:12:00 -0500

bsendas gravatar image

updated 2013-10-25 16:30:17 -0500

smaffulli gravatar image

I have configured Openstack Havana in a single machine using Neutron for networking. When I try to deploy a VM it always shows this error:

{u'message': u'Timeout while waiting on RPC response - topic: "network", RPC method: "get_instance_nw_info" info: "<unknown>"', u'code': 500, u'details': u'  File "/usr/lib/python2.7/dist-packages/nova/compute/manager.py", line 258, in decorated_function |||     return function(self, context, *args, **kwargs)

Any ideas on what's wrong?

edit retag flag offensive close merge delete

Comments

1

Please check for errors in neutron service logs. Post them here if required.

unmesh-gurjar gravatar imageunmesh-gurjar ( 2013-10-24 03:38:59 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
1

answered 2013-10-29 13:06:32 -0500

Benjamin Renard gravatar image

updated 2013-10-29 17:14:02 -0500

I'm having the same issue. I read some information about auth_uri parameter (in neutron.conf) so I setted it but I still have this exception. My instances are in error and when I try to delete them, I'm having a similar exception (RPC method "get_instance_nw_info"). How do you resolv your problem ?

Edit : I finaly found the reason of my problem : the nova configuration about neutron network usage on my hypervisor was incorrect (nova.conf). I just had to copy the configuration of neutron from the nova.conf of my management node.

edit flag offensive delete link more

Comments

I'm having the same issue. What exactly did you copy over?

ionosphere80 gravatar imageionosphere80 ( 2013-10-30 13:20:23 -0500 )edit
1

answered 2013-11-13 21:42:19 -0500

ionosphere80 gravatar image

updated 2013-11-13 21:47:24 -0500

Adding the following directives to nova.conf on the compute node and restarting the nova-compute service resolves this issue for me.

network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = password
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver

I also submitted bug #1251096 against the installation guide.

edit flag offensive delete link more

Comments

this helps, thanks a lot!

mallow gravatar imagemallow ( 2014-04-22 11:55:51 -0500 )edit
0

answered 2013-10-24 08:58:27 -0500

bsendas gravatar image

thanks, it helped. it seems that in Havana the auth_uri variable must be set, although there is no mention of it in the openstack docs

edit flag offensive delete link more

Comments

1

I'm having the same issue. Where did you set it?

marcantonio gravatar imagemarcantonio ( 2013-10-28 13:13:59 -0500 )edit
0

answered 2014-04-22 11:55:05 -0500

mallow gravatar image

the above answer helps

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2013-10-23 13:12:00 -0500

Seen: 4,543 times

Last updated: Apr 22 '14