Ask Your Question
2

invalid openstack identity credentials and http 401 error

asked 2015-03-04 06:19:38 -0500

sumesh s gravatar image

hi I am using ubuntu 14.04 lts server openstack icehouse with mysql database

When I execute the command glance image-list in image service verification phase I am getting two types of error ie if I set enviroment variable

export OS_TENANT_NAME=service

I am getting the error Invalid openstack identity credentials but if I set variable export OS_TENANT_NAME=admin then I gets the error Request you have made requies authentication http 401 error My admin-openrc file is

http://pastebin.com/47EqaCSn

and my glance-api.conf file is

http://pastebin.com/jMQvAPZC
edit retag flag offensive close merge delete

Comments

have you sourced the OS_USERNAME and OS_PASSWORD while using the command "glance image-list"..!!

Praveen N gravatar imagePraveen N ( 2015-03-04 06:42:55 -0500 )edit

yes i sourced the below file content

http://pastebin.com/47EqaCSn

can i add more OS_ variables then please give these parameters

sumesh s gravatar imagesumesh s ( 2015-03-04 11:02:16 -0500 )edit

this is my glance-api.conf file

http://pastebin.com/jMQvAPZC

my glance-registry file http://pastebin.com/5UR3KLpP

sumesh s gravatar imagesumesh s ( 2015-03-05 10:01:43 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-03-04 07:37:31 -0500

Hi, Looks like these errors are caused while configuring the Image Service to use the Identity Service.Your adminopenrc.sh file should be like this:

export OS_USERNAME=admin
export OS_PASSWORD=adminpass
export OS_TENANT_NAME=admin
export OS_AUTH_URL=http://controler:35357/v2.0

Run the command source admin-openrc.sh Now create a glance database user. Create the database tables for the Image Service. Use the service tenant and give the user the admin role:

 keystone user-create --name=glance --pass=GLANCE_PASS --email=glance@example.com
 keystone user-role-add --user=glance --tenant=service --role=admin

Configure the Image Service to use the Identity Service for authentication. Do modifications under the [keystone_authtoken] and [paste_deploy] section. Register the service and create the endpoint.Restart the glance services. Follow these steps correctly as in the guide. Lastly you can verify the glance image installation.

edit flag offensive delete link more
0

answered 2015-03-05 06:23:02 -0500

updated 2015-03-07 03:06:17 -0500

hey there,

the problem here according to me is the database.

#sqlite_db = /var/lib/glance/glance.sqlite

comment the above line. and one more thing make sure your rabbitmq password is correct in glance.

if you are using rabbitmq-server only make rabbit active and comment out all qpid lines as i can see these lines active in your /etc/glance/glance-api.conf

# Configuration options if sending notifications via Qpid (these are
# the defaults)
qpid_notification_exchange = glance
qpid_notification_topic = notifications
qpid_hostname = localhost
qpid_port = 5672
qpid_username =
qpid_password =
qpid_sasl_mechanisms =
qpid_reconnect_timeout = 0
qpid_reconnect_limit = 0
qpid_reconnect_interval_min = 0
qpid_reconnect_interval_max = 0
qpid_reconnect_interval = 0
qpid_heartbeat = 5
# Set to 'ssl' to enable SSL
qpid_protocol = tcp
qpid_tcp_nodelay = True

do the respective changes and restart all the services.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-04 06:19:38 -0500

Seen: 1,901 times

Last updated: Mar 07 '15