glance error in store configuration [closed]

asked 2015-03-03 12:31:02 -0500

DorianT gravatar image

I configured glance as directed here : http://docs.openstack.org/juno/install-guide/install/yum/content/image-service-overview.html (http://docs.openstack.org/juno/instal...)

When I run this command :

    glance image-create --name "cirros-0.3.3-x86_64" --file /tmp/images/cirros-0.3.3-x86_64-disk.img \
 --disk-format qcow2 --container-format bare --is-public True --progress

I get : <html> <head> <title>410 Gone</title> </head> <body>

410 Gone

Error in store configuration. Adding images to store is disabled.

</body> </html> (HTTP N/A)

I have glance configured to use filesystem. Then why is it complaining about store configuration ?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by DorianT
close date 2015-03-09 15:42:00.478091

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-03-09 15:41:21 -0500

DorianT gravatar image

So I fixed it by commenting out file system settings in the default section. Also in glance store section I commented out this line :

#filesystem_store_datadirs = /var/lib/glance/images/:1

so for file system settings this was the only line I had in glance store :

 filesystem_store_datadir = /var/lib/glance/images/
edit flag offensive delete link more
1

answered 2015-03-03 12:46:08 -0500

updated 2015-03-03 12:47:10 -0500

The uploading image capability is disabled in your configuration. See this page for resolution.

edit flag offensive delete link more

Comments

Under [glance_store] I have default_store = file and file directory (filesystem_store_datadir). What else needs to be enabled for glance to upload images?

DorianT gravatar imageDorianT ( 2015-03-03 13:17:45 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-03 12:31:02 -0500

Seen: 9,748 times

Last updated: Mar 09 '15