Ask Your Question
1

Neutron fails to start error - Juno / Ubuntu 14.04 (SOLVED)

asked 2015-03-03 11:09:58 -0500

NateWolfe gravatar image

updated 2015-03-04 17:10:20 -0500

I've been going through the OS Juno Release install on Ubuntu 14.04 and have hit a wall installing neutron. I've been following these instructions: docs.openstack.org/juno/install-guide/install/apt/content/neutron-controller-node.html

Upon start I see the following error(s) in the: /var/log/neutron/server.log

ERROR neutron.common.config [-] Unable to load neutron from configuration file /etc/neutron/api-paste.ini.

I have made no modifications to the api-past.ini file. (No instructions to do so in the install instructions that I saw)

Note: All other services are working and verified up to this point.

I'm stumped at this point... any ideas???

Here is the full /var/log/neutron/server.log output.

2015-03-03 03:30:17.311 12822 INFO neutron.common.config [-] Logging enabled!
2015-03-03 03:30:17.314 12822 INFO neutron.common.config [-] Config paste file: /etc/neutron/api-paste.ini
2015-03-03 03:30:17.378 12822 INFO neutron.manager [-] Loading core plugin: ml2
2015-03-03 03:30:17.442 12822 INFO neutron.plugins.ml2.managers [-] Configured type driver names: ['flat', 'gre']
2015-03-03 03:30:17.444 12822 INFO neutron.plugins.ml2.drivers.type_flat [-] Allowable flat physical_network names: []
2015-03-03 03:30:17.448 12822 INFO neutron.plugins.ml2.managers [-] Loaded type driver names: ['flat', 'gre']
2015-03-03 03:30:17.449 12822 INFO neutron.plugins.ml2.managers [-] Registered types: ['flat', 'gre']
2015-03-03 03:30:17.449 12822 INFO neutron.plugins.ml2.managers [-] Tenant network_types: ['gre']
2015-03-03 03:30:17.450 12822 INFO neutron.plugins.ml2.managers [-] Configured extension driver names: []
2015-03-03 03:30:17.450 12822 INFO neutron.plugins.ml2.managers [-] Loaded extension driver names: []
2015-03-03 03:30:17.451 12822 INFO neutron.plugins.ml2.managers [-] Registered extension drivers: []
2015-03-03 03:30:17.451 12822 INFO neutron.plugins.ml2.managers [-] Configured mechanism driver names: ['openswitch']
2015-03-03 03:30:17.452 12822 ERROR neutron.common.config [-] Unable to load neutron from configuration file /etc/neutron/api-paste.ini.
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config Traceback (most recent call last):
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/neutron/common/config.py", line 183, in load_paste_app
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config     app = deploy.loadapp("config:%s" % config_path, name=app_name)
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config     return loadobj(APP, uri, name=name, **kw)
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 272, in loadobj
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config     return context.create()
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 710, in create
2015-03-03 03:30:17.452 12822 TRACE neutron.common.config     return self.object_type.invoke(self)
2015-03-03 03:30:17.452 ...
(more)
edit retag flag offensive close merge delete

Comments

OK.... I've sorted this out.

After sleeping I started going very carefully through my configs.... The problem was that the nova.conf file had an incorrect rabbitMQ password in it. I used a password that had 2 of the same letters back to back Example: ra'bb'it and only one entered. "rabit"

NateWolfe gravatar imageNateWolfe ( 2015-03-04 13:34:23 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-03-04 13:27:48 -0500

NateWolfe gravatar image

updated 2015-03-04 13:31:20 -0500

Yeah sorry. 14.4 is what I have.... That's what I get for writing this post somewhat sleep deprived...

Edited Title: Complete

edit flag offensive delete link more
1

answered 2015-03-04 05:30:28 -0500

dbaxps gravatar image

updated 2015-03-04 05:33:54 -0500

As far as I remember Juno requires Ubuntu 14.04.
You posted tag 14.04.2 and at the same time in question itself mention 12.04.
What version you are asking about ?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-03 11:09:58 -0500

Seen: 1,023 times

Last updated: Mar 04 '15