Ask Your Question
0

nova services go back to stop state

asked 2015-03-03 08:30:43 -0500

Janki gravatar image

updated 2015-03-03 08:55:11 -0500

dheeru gravatar image

Hi I have 3 node architecture OpenStack setup. Everything was working till yesterday evening. Today all nova services on controller noe i.e. consoleauth, api, conductor, scheduler, and cert show stop status even after starting.

Only log file is nova-manage.log on controller node which is empty.

nova.conf file on controller node is

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata

rpc_backend = rabbit
rabbit_host = controller
rabbit_password = guest

my_ip = 10.107.0.131
vncserver_listen = 10.107.0.131
vncserver_proxyclient_address = 10.107.0.131

auth_strategy = keystone

glance_host = controller

network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = 123
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron

service_neutron_metadata_proxy = true
neutron_metadata_proxy_shared_secret = 123

[database]
connection = mysql://nova:123@controller/nova

[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = 123

on compute node, nova-compute.log says Timed out waiting for nova-conductor. Is it running? Or did this service start before nova-conductor? nova-manage.log file is empty.

I have reinstalled all nova services yet the services didnot start. OS is Ubuntu 14.04 lts and release is Icehouse.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-03-03 08:55:36 -0500

dheeru gravatar image

hello, try this,

nova reset-state server-name/id
edit flag offensive delete link more

Comments

server-name as in service names?

Janki gravatar imageJanki ( 2015-03-03 11:10:13 -0500 )edit
1

server -name/id in the sense you instance name/id you can provide.

PradeepNaik gravatar imagePradeepNaik ( 2015-03-04 01:11:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-03-03 08:30:43 -0500

Seen: 130 times

Last updated: Mar 03 '15