Ask Your Question
1

Network tab not visible in Dashboard

asked 2015-03-02 18:44:43 -0500

mr_element gravatar image

I have installed Devstack on top of Ubuntu Desktop 14.02 . When I log into the Dashboard as Admin I cannot see the "Network" tab which I believe that ultimately, results into my VMs not having external internet access. I want to enable the network tab and I tried by searching around here in the openstack "ask forms". Unfortunately this solution I found did not help: https://wiki.openstack.org/wiki/NeutronDevstack (https://wiki.openstack.org/wiki/Neutr...)

Our local.conf file resides into /devstack/samples directory and here is the relevant part of it:

[[local|localrc]]
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service q-meta



SERVICE_TOKEN=azertytoken
ADMIN_PASSWORD=nomoresecrete
MYSQL_PASSWORD=stackdb
RABBIT_PASSWORD=stackqueue
SERVICE_PASSWORD=$ADMIN_PASSWORD


enable_service tempest

We have also used ./unstack.sh and ./stack.sh scripts after we applied those changes. Any ideas why the network tab in Dashboard is still not visible? Any help would be appreciated.

edit retag flag offensive close merge delete

Comments

Add this line in localrc and re run stack.sh

enable_service neutron

Nicholas I gravatar imageNicholas I ( 2015-03-03 04:37:31 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-03-03 04:30:21 -0500

Nicholas I gravatar image

disable_service n-net enable_service q-svc enable_service q-agt enable_service q-l3 enable_service q-dhcp enable_service q-meta

Add this below line to localrc and re run the stack.sh

enable_service neutron

edit flag offensive delete link more

Comments

That worked you're the man! Thanks!

mr_element gravatar imagemr_element ( 2015-03-03 16:19:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-03-02 18:44:43 -0500

Seen: 1,648 times

Last updated: Mar 03 '15