Ask Your Question
0

br-ex not configured after reboot

asked 2015-03-02 15:09:37 -0500

AlexJ gravatar image

updated 2015-03-02 16:26:48 -0500

Hello!

I ran the packstack wizzard to configure an all in one deployment. I then configured the network files: * ifcfg-eth0

DEVICE=eth0
ONBOOT=yes
NM_CONTROLLED=no
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex

*ifcfg-br-ex

DEVICE="br-ex"
IPADDR="x.x.x.x"
NETMASK="255.255.255.0"
GATEWAY="x.x.x.y"
NM_CONTROLLED="no"
TYPE="OVSBridge"
DEVICETYPE="ovs"
ONBOOT=yes

If I run "systemctl restart network", things get configured ok. If I reboot, network is down. Doing ifdown eth0 br-ex; ifup eth0 br-ex things work. Any idea why?

Thank you!

edit retag flag offensive close merge delete

Comments

Hi, try by specifying the hardware address for eth interface in the network script. Also set DEBUG = yes which displays the debug information when scripts run.

Praveen N gravatar imagePraveen N ( 2015-03-03 04:02:59 -0500 )edit

4 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-02 15:51:07 -0500

mpetason gravatar image

According to the RDO docs, which helped me a ton when setting up Neutron in Havana, you'll need to make sure that the br-ex is set to come up during boot:

DEVICE="br-ex"
IPADDR="x.x.x.x"
NETMASK="255.255.255.0"
GATEWAY="x.x.x.y"
NM_CONTROLLED="no"
TYPE="OVSBridge"
DEVICETYPE="ovs"
ONBOOT=yes

Based on : https://openstack.redhat.com/Neutron_...

edit flag offensive delete link more

Comments

I apologize, I missed that line in the post. I did try with that too. Still didn't work. I tried many combinations. In the post above I tried to put what seems to make sense.

AlexJ gravatar imageAlexJ ( 2015-03-02 16:27:56 -0500 )edit
0

answered 2015-03-03 11:43:22 -0500

AlexJ gravatar image

Adding bug link for documentation purposes: https://bugzilla.redhat.com/show_bug.cgi?id=1051593 (https://bugzilla.redhat.com/show_bug....)

edit flag offensive delete link more
0

answered 2015-03-03 02:01:17 -0500

dbaxps gravatar image

Old versions of OVS require lines in /etc/rc.d/rc.local file:-

ifdown br-ex ;
ifup br-ex ;
service network restart ;

It's known record in Bugzilla. On F21 it is already not needed.

edit flag offensive delete link more

Comments

I did that hack, and I had another issue: neutron-server stopped working. I did get the IP, but in systemctl, neutron-server.service was 'failed'. So I added systemctr restart neutron-server to rc.local. But that caused some swift services to fail. So I aded them, which caused iscsi to fail.

AlexJ gravatar imageAlexJ ( 2015-03-05 00:14:12 -0500 )edit
0

answered 2015-03-03 03:34:44 -0500

Nicholas I gravatar image

Disable default Network Manager and Reboot the system.

edit flag offensive delete link more

Comments

First thing I did. Not the issue.

AlexJ gravatar imageAlexJ ( 2015-03-05 00:11:06 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2015-03-02 15:08:16 -0500

Seen: 1,747 times

Last updated: Mar 03 '15