Ask Your Question
0

devstack installation: Access denied for user 'root'@'localhost'

asked 2015-02-26 09:55:54 -0500

AlonFre gravatar image

updated 2015-03-02 02:16:09 -0500

Hi all,

we are trying to install devstack using the multi-node installation guide, when running the stack.sh script, we get this error:

2015-02-26 14:55:43.150 | + sudo mysql -uroot -psupersecret -h127.0.0.1 -e 'GRANT ALL PRIVILEGES ON *.* TO '\''root'\''@'\''%'\'' identified by '\''supersecret'\'';' 
2015-02-26 14:55:44.222 | ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

Do you have any idea what can be the problem?

The local.conf file is configured as follow:

OST_IP=132.72.111.144
FLAT_INTERFACE=eth0
FIXED_RANGE=10.4.128.0/20
FIXED_NETWORK_SIZE=4096
FLOATING_RANGE=192.168.42.128/25
MULTI_HOST=1
LOGFILE=/opt/stack/logs/stack.sh.log
ADMIN_PASSWORD=labstack
MYSQL_PASSWORD=supersecret
RABBIT_PASSWORD=supersecrete
SERVICE_PASSWORD=supersecrete
SERVICE_TOKEN=xyzpdqlazydog

Thanks in advance,

Alon

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-26 12:11:40 -0500

Hey Alon, tell whether you have logged in as a root user?

How have you configured your local.conf file?

What is the host IP w.r.t your setup?

edit flag offensive delete link more

Comments

hey Yashpal, thanks for your response. i'm looged as the "stack" user, which has sudo privileges. the local.conf connfiguration is attached now to the original question. the host ip is: 132.72.111.144 any ideas? thanks, Alon.

AlonFre gravatar imageAlonFre ( 2015-03-02 02:12:37 -0500 )edit

Hi Alon,

  1. Have you made appropriate changes in /etc/network/interfaces?
  2. OST_IP=132.72.111.144, H is misssing
  3. Are you able to login into mysql by $mysql -u root -p supersecret
Yashpal Beppurana gravatar imageYashpal Beppurana ( 2015-03-02 07:33:01 -0500 )edit
2

answered 2015-12-14 18:29:14 -0500

Asterix gravatar image

Use the below command to reset the root password for mysql:

sudo dpkg-reconfigure mysql-server-5.5

the new password should be the MYSQL_PASSWORD in your local.conf file (in this case supersecret)

edit flag offensive delete link more

Comments

The following steps on CentOS resolved the the issue for me.

./unstack.sh

sudo yum -y remove MySQL-python.x86_64 sudo yum -y remove perl-DBD-MySQL.x86_64 sudo yum -y remove postgresql.x86_64 sudo yum -y remove postgresql-libs.x86_64

sudo rm -rf /var/lib/mysql/ /etc/mysql/

./stack.sh

Vikram Hosakote gravatar imageVikram Hosakote ( 2016-11-30 15:25:39 -0500 )edit
0

answered 2016-11-30 15:24:59 -0500

updated 2016-11-30 15:39:19 -0500

The following steps on CentOS resolved the the issue for me.

./unstack.sh

sudo yum -y remove MySQL-python.x86_64

sudo yum -y remove perl-DBD-MySQL.x86_64

sudo yum -y remove postgresql.x86_64

sudo yum -y remove postgresql-libs.x86_64

sudo rm -rf /var/lib/mysql/ /etc/mysql/

./stack.sh

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-26 09:55:54 -0500

Seen: 5,784 times

Last updated: Nov 30 '16