Ask Your Question
0

cannot ping external network from vm

asked 2015-02-25 14:48:17 -0500

rlastinger gravatar image

updated 2015-02-25 23:21:44 -0500

I am running packstack Juno all-in-one with nova-network only (no neutron) on bare metal. I did not install ironic.

I have one interface. The bridge and iptables setup is however it is setup by default.

I can ping and ssh into my VMs over the VPN or at home, but when in the VM, I can ping the host interface of the openstack server, the private ip and floating ip of other vms, but cannot ping anything on the internet or anything else on my network.

All of the connectivity seems to be confined with the the all-in-one environment. How can I get the vms routing both internally and externally with nova?

interface list:

br100: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 10.3.4.4  netmask 255.255.255.0  broadcast 10.3.4.255
    inet6 fe80::507c:3fff:fe7a:65b9  prefixlen 64  scopeid 0x20<link>
    ether 0c:c4:7a:34:a2:d1  txqueuelen 0  (Ethernet)
    RX packets 135135  bytes 11300423 (10.7 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 24286  bytes 16804729 (16.0 MiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eno1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 0c:c4:7a:34:a2:d0  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eno2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.129.1  netmask 255.255.255.255  broadcast 0.0.0.0
        inet6 fe80::ec4:7aff:fe34:a2d1  prefixlen 64  scopeid 0x20<link>
        ether 0c:c4:7a:34:a2:d1  txqueuelen 1000  (Ethernet)
        RX packets 133225  bytes 13050773 (12.4 MiB)
        RX errors 75  dropped 779  overruns 0  frame 75
        TX packets 27427  bytes 16817407 (16.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 7581844  bytes 1055579338 (1006.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 7581844  bytes 1055579338 (1006.6 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet6 fe80::fc16:3eff:fe19:bbb0  prefixlen 64  scopeid 0x20<link>
        ether fe:16:3e:19:bb:b0  txqueuelen 500  (Ethernet)
        RX packets 461  bytes 42764 (41.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1449  bytes 119663 (116.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

brctl show:

bridge name bridge id       STP enabled interfaces
br100       8000.0cc47a34a2d1   no      eno2
                                        vnet0
edit retag flag offensive close merge delete

Comments

If you installed RDO Juno ( from RH), then nova network was deprecated in RDO in Havana release I believe.

dbaxps gravatar imagedbaxps ( 2015-02-25 15:14:39 -0500 )edit

In the answers file, it had a flag for installing nova and neutron. I configured Nova=y and Neutron=n. I assumed that meant nova only.

rlastinger gravatar imagerlastinger ( 2015-02-25 15:40:24 -0500 )edit

quick question... should the ip address of br100 be the same IP as the gateway IP in the nova database?

in my setup, my br100 ip is 10.3.4.4 and route -n on the vm host says the gateway is 10.3.4.4, but the nova network database says the gateway is 10.3.4.1.

rlastinger gravatar imagerlastinger ( 2015-02-25 22:38:02 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-26 19:30:29 -0500

rlastinger gravatar image

packstack did not create the route for the bridge interface br100.

fixed this with iptables -t nat -A POSTROUTING -o br100 -j MASQUERADE

edit flag offensive delete link more
0

answered 2015-02-25 22:54:49 -0500

Make sure of followings.

  • br-ex is assigned IP of your external network external adapter is set into promisc mode external adapter is added into br-ex You have created external network in OpenStack External Network is connected to Neutron router.
edit flag offensive delete link more

Comments

I don't have an option to create a neutron router and do not have br-ex. I have br100 which has the ip address of my private ip for nova-network.

rlastinger gravatar imagerlastinger ( 2015-02-25 23:18:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2015-02-25 14:48:17 -0500

Seen: 1,003 times

Last updated: Feb 26 '15