Ask Your Question
2

Instance failed to spawn

asked 2015-02-25 11:07:27 -0500

bibin gravatar image

Hi,

I am following the openstack juno user guide for Opensuse and while creating instance by using the neutron network, it fails with the errors as below,

##Getting following error at looking the compute logs

2015-02-25 18:55:08.109 503 TRACE nova.compute.manager [instance: 9402ecd5-cfc7-439f-8137-909baa56e216] _("Unexpected vif_type=%s") % vif_type)

2015-02-25 18:55:08.109 503 TRACE nova.compute.manager [instance: 9402ecd5-cfc7-439f-8137-909baa56e216] NovaException: Unexpected vif_type=binding_failed

########Getting following errors at looking neutron-openvswitch-agent logs

2015-02-25 20:21:38.434 21768 WARNING neutron.agent.securitygroups_rpc [req-e3feb5c2-9fc5-4d45-af92-04fa2e70ef4c None] Driver configuration doesn't match with enable_security_group

2015-02-25 20:21:38.435 21768 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-e3feb5c2-9fc5-4d45-af92-04fa2e70ef4c None] Agent initialized successfully, now running...

2015-02-25 20:21:38.449 21768 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [req-e3feb5c2-9fc5-4d45-af92-04fa2e70ef4c None] Agent out of sync with plugin!

##########getting following errors at looking neutron-server log.

2015-02-25 20:24:05.508 17170 INFO keystonemiddleware.auth_token [-] Starting keystone auth_token middleware

2015-02-25 20:24:05.510 17170 INFO keystonemiddleware.auth_token [-] Using /var/cache/neutron/keystone-signing as cache directory for signing certificate

2015-02-25 20:24:05.510 17170 WARNING keystonemiddleware.auth_token [-] signing_dir is not owned by 0

2015-02-25 20:24:35.576 17170 ERROR neutron.service [-] Unrecoverable error: please check log for details.

2015-02-25 20:24:35.576 17170 TRACE neutron.service RuntimeError: Could not bind to 0.0.0.0:9696 after trying for 30 seconds

Please advise me.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-03-02 08:45:09 -0500

bibin gravatar image

I have sorted that issue. As per the guide,I had configured the ovs plugin in the ml2 conf file. When I checked the ovs service log, which is looking to the openvswitch configuration file( ovs_neutron_plugin.ini). Thanks

edit flag offensive delete link more

Comments

how do you solve that issue??

GLaupre gravatar imageGLaupre ( 2015-03-25 18:37:58 -0500 )edit

Configure the ovsplugin instead of ml2(located on/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini )

bibin gravatar imagebibin ( 2015-03-30 07:36:46 -0500 )edit
0

answered 2015-02-27 04:32:43 -0500

Vinoth gravatar image

I suspect all your neutron service were not running. Make sure you have smileys :-) in all rows, while executing the command " neutron agent-list"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-25 11:07:27 -0500

Seen: 1,618 times

Last updated: Mar 02 '15