Ask Your Question
0

RDO rerun - Qrouters lose IP address on public network

asked 2015-02-25 02:07:51 -0500

agti gravatar image

Hi, whenever I rerun packstack in order for example to add a compute node, already present qrouters lose their ip address on public network, resulting in unavailable connectivity with VM floating IP.

Is there a command to reconfigure qrouters? Now I'm doing it manually, removing all floating ips from VMs, clearing the router gateway and adding it again, reassingning then all VMs floating IPs.

Is anyone experiencing the same problem?

Thanks in advance.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-25 04:34:00 -0500

dbaxps gravatar image

You wrote "Now I'm doing it manually, removing all floating ips from VMs, clearing the router gateway and adding it again, reassingning then all VMs floating IPs."

I would write once for a while  shell script doing all this work, after packstack completition.
edit flag offensive delete link more

Comments

ok, you are right, but is this an expected behavior? I mean, is it correct to lose gateway infos on qrouters?

agti gravatar imageagti ( 2015-02-25 05:07:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-25 02:07:51 -0500

Seen: 105 times

Last updated: Feb 25 '15