Ask Your Question
0

Should the tenant router gateway be accessible from the network node itself ?

asked 2015-02-24 16:58:17 -0500

calm07 gravatar image

updated 2015-02-26 18:02:57 -0500

I am trying to setup the 3-node (controller, neutron and compute) openstack configuration on 3 Virtual machines running on Virtualbox. I have enabled promiscous mode on the external network as suggested in the manual. In the verify connectivity step - here ( http://docs.openstack.org/juno/install-guide/install/apt/content/neutron_initial-networks-verify.html (http://docs.openstack.org/juno/instal...) ), it says that "you should be able to ping the IP address of the tenant router gateway from any host on your external physical network." I am able to do that from the controller and compute nodes which are on the physical network. But when I try to do that from the network node (which has the tenant router on it) , it cannot ping it. Does this mean that there is an error in my setup ? If so, any pointers on how to troubleshoot it would be very welcome.

Edit 1 in reply to response - After configuring the network node as mentioned in the manual, I am able to launch an instance, but the network node no longer connects to the external network and so the instance is not able to as well. I have read through similar discussions on this forum and elsewhere but could not find a clear solution. I think I am not bridging the interfaces as they should be bridged. I am including my /etc/network/interface file of the network node as well as the outputs of some of the network-related commands that are often asked in such situations.

Configuration Detail - 3 VM's running Ubuntu 14.04 on VirtualBox. The management and tunnel networks are on eth1 and eth2 and are configured as internal networks. Static ip's are set on 10.0.0/24 and 10.0.1/24 respectively. The external network is on eth0 and is configured using the NatNetwork adapter that Virtualbox provides. ( https://www.virtualbox.org/manual/ch06.html#network_nat_service (https://www.virtualbox.org/manual/ch0...) ) . Basically the host and guests can see each other and the guest machines can access internet using the host (similar to NAT adapter in that aspect.). This works on the compute and controller nodes and used to work on the network node before I configured neutron setup on the network node. I set a static ip on this in the 192.168.16/24 subnet. A part of this is used for the virtual external network on the neutron node.

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-26 18:03:30 -0500

calm07 gravatar image

Edit 2 - I found the solution. I had initially set a static ip for the external network on the network node because I needed internet access to install packages. So the bridge was not correctly configured. I deleted br-ex, br-tun and then added them as described in the manual. I then edited my interfaces file as shown below and added a static ip for br-ex. Restart the eth0 and br-ex interfaces, neutron services and possibly the openvswicth agent and service on the compute node as well. Delete old network and subnets and create new ones. I am now able to ssh into my instance and ping the external network from my instance. I do have one remaining issue, my instance can ping external ip addresses, but it cannot resolve names say "google.com" for example. Any suggestions ?

/etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback


# External network

# The public network interface
auto eth0
iface eth0 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

auto br-ex
iface br-ex inet static
address 192.168.16.6
netmask 255.255.255.0
gateway 192.168.16.1
dns-nameservers 128.46.154.76 128.210.11.5 128.210.11.57

#Management Inetrface
auto eth1
iface eth1 inet static
address 10.0.0.21
netmask 255.255.255.0

# VM tunneling interface
auto eth2
iface eth2 inet static
address 10.0.1.21
netmask 255.255.255.0
edit flag offensive delete link more

Comments

The following link was very useful - https://github.com/ChaimaGhribi/OpenStack-Icehouse-Installation/blob/master/OpenStack-Icehouse-Installation.rst#configure-compute-node (https://github.com/ChaimaGhribi/OpenS...)

calm07 gravatar imagecalm07 ( 2015-02-26 18:04:29 -0500 )edit
0

answered 2015-11-02 02:49:20 -0500

updated 2015-11-02 02:51:07 -0500

I have similar setup but not able to ping external IP when trying to see neutron net-list it showing below error You must provide a username or user ID via --os-username, env[OS_USERNAME] or --os-user-id, env[OS_USER_ID]

tried with neutron net-list --os-username root but that is also some kind of error below You must provide a project_id or project_name (with project_domain_name or project_domain_id) via --os-project-id (env[OS_PROJECT_ID]) --os-project-name (env[OS_PROJECT_NAME]), --os-project-domain-id (env[OS_PROJECT_DOMAIN_ID]) --os-project-domain-name (env[OS_PROJECT_DOMAIN_NAME])

edit flag offensive delete link more
0

answered 2015-02-25 05:45:39 -0500

Vinoth gravatar image

No, You are almost done. Now try launching the VMs. It should able to connect with internet. If you face any problem, then post your /etc/network/interface file here .

edit flag offensive delete link more

Comments

Thanks a lot for the quick reply. I have added edits to the question according to your comment. Any pointers as to where to start debugging would be highly appreciated.

calm07 gravatar imagecalm07 ( 2015-02-25 18:25:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-24 16:58:17 -0500

Seen: 639 times

Last updated: Nov 02 '15