Ask Your Question
1

amqp server connection problem (Adding node with RDO)

asked 2015-02-24 05:42:21 -0600

agti gravatar image

updated 2015-02-24 05:50:38 -0600

Hi, I'm trying to add a compute node on my RDO 3 nodes installation. It seems the new compute can't connect to rabbit on controller node.

nova.log:

2015-02-24 12:45:33.197 11723 INFO oslo.messaging._drivers.impl_rabbit [req-228b4daf-9ee1-4940-a988-0497a86ba4c8 ] Delaying reconnect for 1.0 seconds...
2015-02-24 12:45:34.199 11723 INFO oslo.messaging._drivers.impl_rabbit [req-228b4daf-9ee1-4940-a988-0497a86ba4c8 ] Connecting to AMQP server on CONTROLLER-IP:5672
2015-02-24 12:45:34.206 11723 ERROR oslo.messaging._drivers.impl_rabbit [req-228b4daf-9ee1-4940-a988-0497a86ba4c8 ] AMQP server on CONTROLLER-IP:5672 is unreachable: [Errno 113] EHOSTUNREACH. Trying again in 15 seconds.

I also tried telnet controller 80 and it works, but telnet controller 5672 says No Route To Host.

I double checked, rabbit correctly works on controller node (already present and active services could communicate with it)

What could it be? I tried disabling firewall but it does not help.

edit retag flag offensive close merge delete

Comments

What says on Controller ?

$netstat -lntp | grep 5672
$iptables-save | grep 5672
dbaxps gravatar imagedbaxps ( 2015-02-24 05:57:34 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-02-24 06:58:30 -0600

agti gravatar image

updated 2015-02-24 07:50:13 -0600

[root@juno-controller ~]# netstat -lntp | grep 5672
tcp        0      0 0.0.0.0:25672           0.0.0.0:*               LISTEN      6987/beam.smp
tcp6       0      0 :::5672                 :::*                    LISTEN      6987/beam.smp
[root@juno-controller ~]# iptables-save | grep 5672
-A INPUT -s x.y.z.60/32 -p tcp -m multiport --dports 5671,5672 -m comment --comment "001 amqp incoming amqp_x.y.z.60" -j ACCEPT
-A INPUT -s x.y.z.61/32 -p tcp -m multiport --dports 5671,5672 -m comment --comment "001 amqp incoming amqp_x.y.z.61" -j ACCEPT
-A INPUT -s x.y.z.62/32 -p tcp -m multiport --dports 5671,5672 -m comment --comment "001 amqp incoming amqp_x.y.z.62" -j ACCEPT

Seems that RDO packstack is not adding the correct iptables rule for the new host (x.y.z.57). Is it correct? Do I have to insert it manually?

UPDATE

It was my fault, I inserted the controller IP in EXCLUDE_SERVERS list in answer file. I then realized that also the controller need some configuration changes!

Removing it from the list did the trick!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-24 05:42:21 -0600

Seen: 1,642 times

Last updated: Feb 24 '15