Ask Your Question
0

CRITICAL keystone [-] NoSuchOptError: no such option in group cache: memcache_servers [closed]

asked 2015-02-23 22:09:20 -0600

RedCricket gravatar image

updated 2015-02-24 11:21:24 -0600

Hi,

I am trying to deploy Juno with puppet modules I used for Havana. I am stumped and do not know how to debug this ... When I try and start the openstack-keystone service I get this error message in the /var/log/keystone/keystone.log file:

CRITICAL keystone [-] NoSuchOptError: no such option in group cache: memcache_servers

I looked in my /etc/keystone/keystone.conf file and I do not even have a cache group nor do I have a memcache_servers option anywhere either.

Here's my keystone.conf:

[DEFAULT]
admin_token = my_keystone
bind_host = 10.29.103.51
debug = true
verbose = True

[sql]
connection = mysql://keystone:1234@ost-el7.example.com:3306/keystone
max_retries = 10
retry_interval = 10
max_pool_size = 75
idle_timeout = 120
max_overflow = 150

[identity]
driver = keystone.identity.backends.hybrid.Identity

[catalog]
driver = keystone.catalog.backends.sql.Catalog

[token]
driver = keystone.token.backends.memcache.Token
expiration = 10800

[assignment]
driver = keystone.assignment.backends.sql.Assignment

[signing]
token_format = UUID

[ldap]
url = ldap://ds.example.com:389
password = XXXXXXX
user = xxxx-xxxx.gen
suffix = OU=Example Users,DC=my,DC=com
user_suffix = @example.com
user_tree_dn = ou=Employees,ou=Example Users,dc=example,dc=com
generic_tree_dn = ou=Generics,ou=Example Users,dc=example,dc=com
use_dumb_member = False
allow_subtree_delete = False
user_objectclass = person
user_enabled_attribute = userAccountControl
user_enabled_mask = 2
user_enabled_default = 512
page_size = 500
query_scope = one
user_id_attribute = cn
user_name_attribute = cn

[auth]
methods = password,token
password = keystone.auth.plugins.password.Password
token = keystone.auth.plugins.token.Token
oauth1 = keystone.auth.plugins.oauth1.OAuth

[memcache]
servers = 10.0.0.51:11211,10.0.0.52:11211,10.0.0.53:11211
expiration = 7200

Update:

Here's what's in my /var/log/keystone/keystone.log file:

2015-02-24 02:09:54.119 6013 DEBUG keystone.common.environment [-] Environment configured as: eventlet wrapper /usr/lib/python2.7/site-packages/keystone/common/environment/__init__.py:49
2015-02-24 02:09:54.127 6013 CRITICAL keystone [-] NoSuchOptError: no such option in group cache: memcache_servers
2015-02-24 02:09:54.127 6013 TRACE keystone Traceback (most recent call last):
2015-02-24 02:09:54.127 6013 TRACE keystone   File "/usr/bin/keystone-all", line 146, in <module>
2015-02-24 02:09:54.127 6013 TRACE keystone     backends.load_backends()
2015-02-24 02:09:54.127 6013 TRACE keystone   File "/usr/lib/python2.7/site-packages/keystone/backends.py", line 29, in load_backends
2015-02-24 02:09:54.127 6013 TRACE keystone     cache.configure_cache_region(cache.REGION)
2015-02-24 02:09:54.127 6013 TRACE keystone   File "/usr/lib/python2.7/site-packages/keystone/common/cache/core.py", line 140, in configure_cache_region
2015-02-24 02:09:54.127 6013 TRACE keystone     config_dict = build_cache_config()
2015-02-24 02:09:54.127 6013 TRACE keystone   File "/usr/lib/python2.7/site-packages/keystone/common/cache/core.py", line 114, in build_cache_config
2015-02-24 02:09:54.127 6013 TRACE keystone     CONF.cache.memcache_servers)
2015-02-24 02:09:54.127 6013 TRACE keystone   File "/usr/lib/python2.7/site-packages/oslo/config/cfg.py", line 2313, in __getattr__
2015-02-24 02:09:54.127 6013 TRACE keystone     return self._conf._get(name, self._group)
2015-02-24 02:09:54.127 6013 TRACE keystone   File "/usr/lib/python2 ...
(more)
edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2015-02-24 21:29:16.639740

Comments

Do you have python-memcached installed?

SamYaple gravatar imageSamYaple ( 2015-02-24 00:01:27 -0600 )edit

Thanks for the reply! Yep ... # rpm -q python-memcached python-memcached-1.48-4.el7.noarch

RedCricket gravatar imageRedCricket ( 2015-02-24 00:24:36 -0600 )edit

Can you post your /etc/keystone/keystone-paste.ini to make sure that is clean? Do you get an additional stack trace or anything in the logs? memcache_servers is a valid option in the keystone section of the other projects, so verify what log that error is from please.

SamYaple gravatar imageSamYaple ( 2015-02-24 01:05:01 -0600 )edit

Thanks for the suggestion Sam. I have updated my question

RedCricket gravatar imageRedCricket ( 2015-02-24 01:15:59 -0600 )edit

strange indeed. Check your logging.conf for a [cache] section. Past that I would run the keystone binary directly and only pass it the single config file. Check your service startup script to make sure the conf passed are correct.

SamYaple gravatar imageSamYaple ( 2015-02-24 01:30:40 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-02-24 13:44:16 -0600

RedCricket gravatar image

I found the answer to my issue. Turns out that the developer of the puppet modules I am using made a change to /usr/lib/python2.7/site-packages/keystone/common/config.py file and injected these changes via a puppet erb file. I removed these references from the puppet code and refreshed my controller node and the problem went away. :)

edit flag offensive delete link more

Comments

and here I was going to suggest some hashing of files and I said "Nah, there is no way they were messing with that". Glad its working for you!

SamYaple gravatar imageSamYaple ( 2015-02-24 21:29:09 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-23 22:09:20 -0600

Seen: 2,167 times

Last updated: Feb 24 '15