Ask Your Question
0

keystone HTTP 500 error

asked 2015-02-23 13:05:09 -0500

DorianT gravatar image

Hi all --

I'm trying to set up keystone and while create the admin tenant, I get this error :

An unexpected error prevented the server from fulfilling your request. (HTTP 500)

Looking at logs I see :

OperationalError: (OperationalError) (1045, "Access denied for user 'keystone'@'allinone' (using password: YES)") None None

I created the keystone database and users as directed and gave privileges to keystone user on %, localhost and allinone.

What else needs to be done for this ?

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
2

answered 2015-02-23 13:29:23 -0500

smaffulli gravatar image

Mysql is complaining. Check the database credentials you're passing to it.

edit flag offensive delete link more

Comments

Changed the password for keystone user in mysql and it worked. Thanks!

DorianT gravatar imageDorianT ( 2015-02-23 16:07:24 -0500 )edit

Please can you explain how to change the password ?

Ahmed Morgan gravatar imageAhmed Morgan ( 2015-08-01 17:50:21 -0500 )edit
0

answered 2016-06-29 06:20:34 -0500

nareng gravatar image

updated 2016-06-29 06:30:51 -0500

If ur using kilo version

when using curl it's downloading text context form the git hub and appending on main and admin curl http://git.openstack.org/cgit/openstack/keystone/plain/httpd/keystone.py?h=stable/kilo (http://git.openstack.org/cgit/opensta...) \ | tee /var/www/cgi-bin/keystone/main /var/www/cgi-bin/keystone/admin

the content should like below if it not copy and paste on both file main and admin

# Copyright 2015 OpenStack Foundation

#

# Licensed under the Apache License, Version 2.0 (the "License"); you may

# not use this file except in compliance with the License. You may obtain

# a copy of the License at

#

# http://www.apache.org/licenses/LICENSE-2.0 (http://www.apache.org/licenses/LICENS...)

#

# Unless required by applicable law or agreed to in writing, software

# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT

# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the

# License for the specific language governing permissions and limitations

# under the License.

import os

from keystone.server import wsgi as wsgi_server

name = os.path.basename(__file__)

# NOTE(ldbragst): 'application' is required in this context by WSGI spec.

# The following is a reference to Python Paste Deploy documentation

# http://pythonpaste.org/deploy/

application = wsgi_server.initialize_application(name)

If this not there keystone will not import db

edit flag offensive delete link more
1

answered 2015-08-07 17:43:17 -0500

thierryv8 gravatar image

Hi,

I navigated between many forums to figure out the answer and I found out a good solution, which is working for me:

Instead of typing the command: # su -s /bin/sh -c "keystone-manage db_sync" keystone, you must type only: /bin/sh -c "keystone-manage db_sync" keystone

The issue came that: if you have already loggin as a root so you haven't needed anymore to use the "su -s" command at the beginning.

After that, you can execute the command: openstack service create --name keystone ==description "OpenStack Identity" identity, which will work perfectly fine.

by thierryv8

edit flag offensive delete link more

Comments

This answer worked for me when following the latest Liberty documentation. I didn't have to change any db passwords or whatnot. This should be the accepted answer.

msanabria11 gravatar imagemsanabria11 ( 2016-03-03 09:21:21 -0500 )edit

I have struggled with the same issue, but none of them seem to work. I am trying to install liberty on centos 7. Have changed the /etc/keystone/keystone.conf "connection = mysql://keystone:keystone123@localhost/keystone" had controller earlier instead of localhost. None of these seem to work

DarkKnight gravatar imageDarkKnight ( 2016-04-18 02:08:22 -0500 )edit

https://ask.openstack.org/en/question... : Link to my posted question. kindly help

DarkKnight gravatar imageDarkKnight ( 2016-04-18 02:09:47 -0500 )edit

Thank you, this has worked for me, installation guide is a bit inconsistent as most commands are as root, so you naturally put that in as root as well

eriksh7 gravatar imageeriksh7 ( 2017-01-01 21:26:41 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-23 13:05:09 -0500

Seen: 6,695 times

Last updated: Jun 29 '16