pip wheel' requires setuptools >= 0.8 for dist-info support

asked 2015-02-23 07:33:11 -0500

Emad gravatar image

I am trying to run devstack ./stack.sh, however it gives me this error:

ERROR: 'pip wheel' requires setuptools >= 0.8 for dist-info support. To fix this, run: pip install --upgrade setuptools

I tried different commands such as:

pip install --upgrade setuptools

or

sudo pip install setuptools --no-use-wheel --upgrade

However in all cases I get this:

The directory '/home/nik/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want the -H flag.

Requirement already up-to-date: setuptools in /usr/local/lib/python2.7/dist-packages
edit retag flag offensive close merge delete