Ask Your Question
0

Round Robin nova-novncproxy problem

asked 2015-02-21 18:02:04 -0600

RyanKuba gravatar image

I have an active/active juno setup working except for an annoying little thing. The two central servers site behind HA proxy and this includes the nova-novncproxy on port 6080. The console works for vms on compute nodes but you need to go to fullscreen or reload the page to see it in the Horizon web interface as it will randomly give a code 1006.

Was wondering if anyone had exeperience with round robing vnc proxy nodes?

To give you an example when I first pull up the page I get:

http://www.ryankuba.com/DropBox/bad.png (Bad)

But when I go fullscreen or randomly in the horizon interface I get:

http://www.ryankuba.com/DropBox/good.png (image description)

Thanks for looking.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-02-22 05:09:12 -0600

SamYaple gravatar image

updated 2015-02-22 05:11:08 -0600

You will need to use memcached in your nova.conf for the console-auth servers.

Simply set memcached_servers= in the [DEFAULT] section of your nova.conf and restart the console-auth services and you should be good.

It is an undocumented dependancy of multiple active console-auths. I'll submit a patch to the ha-guide section in the docs.

Example:

memcached_servers = controller01:11211, controller02:11211
edit flag offensive delete link more

Comments

Worked like a charm thank you!

RyanKuba gravatar imageRyanKuba ( 2015-03-11 00:44:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-21 18:02:04 -0600

Seen: 312 times

Last updated: Feb 22 '15