Ask Your Question
0

My router both interfaces are Down

asked 2015-02-21 01:54:02 -0500

C:\fakepath\2015-02-21_13-18-20.png

please check my router interface

i dont know why im getting both the interfaces are

down and my base machine also not getting the internet

only ping the LAN but not WAN

edit retag flag offensive close merge delete

Comments

Post ovs-vsctl show and ifconfig on Network node.

dbaxps gravatar imagedbaxps ( 2015-02-21 04:19:58 -0500 )edit

Make sure you do the following :

  1. Add bridge br-ex

  2. Specify br-ex in /etc/neutron/l3_agent.ini external_network_bridge = br-ex

  3. Restart neutron l3 agent

Hope this helps!!!

teju gravatar imageteju ( 2015-02-23 00:55:33 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-24 00:46:01 -0500

If the module's hardware information is not shown in the show diag, reseat the hardware module. You can also install the module in a different slot. Some modules are not hot swappable; reload the router after you install the module. If the module's hardware information is shown in the show diag but you are not able to see the module interfaces in the show run or show IP interface brief output, check the hardware installation documentation. Some modules need router configuration after the installation. For any writing kind of help you can use this http://top5essaywriters.com (essay writing service review) for getting a best support.

edit flag offensive delete link more
0

answered 2015-02-23 23:26:58 -0500

madhank gravatar image

updated 2015-02-23 23:34:31 -0500

check have you done this on your vi /etc/neutron/plugins/ml2/ml2_conf.ini

[ml2]

type_drivers = flat,gre

tenant_network_types = gre

mechanism_drivers = openvswitch

[ml2_type_flat]

flat_networks = external

[ml2_type_gre]

tunnel_id_ranges = 1:1000

[securitygroup]

enable_security_group = True

enable_ipset = True

firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

[ovs]

local_ip = INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS

enable_tunneling = True

bridge_mappings = external:br-ex

save the file

If you already configured,Check your /etc/network/interface do as below

change your external bridge interface like below if

auto eth2

iface eth2 inet manual

up ip address add 0/0 dev $IFACE

up ip link set $IFACE up

down ip link set $IFACE down

auto br-ex

iface br-ex inet static

address 172.16.5.3

netmask 255.255.0.0

network 172.16.5.0

broadcast 172.16.5.255

gateway 172.16.5.1

save it and restart the neutron services

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-21 01:54:02 -0500

Seen: 1,317 times

Last updated: Feb 23 '15