Ask Your Question
0

swiftclient Account HEAD failed 503 internal server error

asked 2015-02-19 10:26:04 -0500

eugene.goldberg gravatar image

I have installed swift and keystone on top of a fresh Fedora 21

My keystone endpoint looks like this:

6c063f73bc0041e09a0c0d65193e0285 | RegionOne | http://127.0.0.1:8080/v1/AUTH_c36b8bb29ea947ce922f42389004648b | http://127.0.0.1:8080/v1 | http://127.0.0.1:8080/v1 | 8c90a8900abe45ad83aa5b04df957e80

My proxy-server.conf file looks like this:

[DEFAULT]
bind_port = 8080
user = swift

[pipeline:main]
pipeline = healthcheck cache authtoken keystoneauth proxy-server

[app:proxy-server]
use = egg:swift#proxy
allow_account_management = true
account_autocreate = true

[filter:keystoneauth]
use = egg:swift#keystoneauth
operator_roles = Member,admin,swiftoperator

[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

# Delaying the auth decision is required to support token-less
# usage for anonymous referrers ('.r:*').
delay_auth_decision = true
# auth_* settings refer to the Keystone server
auth_protocol = http
auth_host = 127.0.0.1
auth_port = 35357
# the service tenant and swift username and password created in Keystone
admin_tenant_name = admin
admin_user = admin
admin_password = mast3r

[filter:cache]
use = egg:swift#memcache

[filter:catch_errors]
use = egg:swift#catch_errors

[filter:healthcheck]
use = egg:swift#healthcheck

My /etc/memcached.conf file looks like this:

[memcache]
# You can use this single conf file instead of having memcache_servers set in
# several other conf files under [filter:cache] for example. You can specify
# multiple servers separated with commas, as in: 10.1.2.3:11211,10.1.2.4:11211
# memcache_servers = 127.0.0.1:11211
#
# Sets how memcache values are serialized and deserialized:
# 0 = older, insecure pickle serialization
# 1 = json serialization but pickles can still be read (still insecure)
# 2 = json serialization only (secure and the default)
# To avoid an instant full cache flush, existing installations should
# upgrade with 0, then set to 1 and reload, then after some time (24 hours)
# set to 2 and reload.
# In the future, the ability to use pickle serialization will be removed.
# memcache_serialization_support = 2
#
# Sets the maximum number of connections to each memcached server per worker
# memcache_max_connections = 2
#
# Timeout for connection
# connect_timeout = 0.3
# Timeout for pooled connection
# pool_timeout = 1.0
# number of servers to retry on failures getting a pooled connection
# tries = 3
# Timeout for read and writes
# io_timeout = 2.0
-l proxy-server-ip 127.0.0.1

The output of keystone tenant-list looks like this:

c36b8bb29ea947ce922f42389004648b | admin |   True

When I run swift --debug stat I get the following error:

INFO:swiftclient:RESP HEADERS: [('date', 'Thu, 19 Feb 2015 16:24:37 GMT'), ('content-length', '0'), ('content-type', 'text/html; charset=UTF-8'), ('connection', 'keep-alive'), ('x-trans-id', 'txb8f78eb0f06d4ab286cc0-0054e60e45')]
DEBUG:requests.packages.urllib3.connectionpool:"HEAD /v1/AUTH_c36b8bb29ea947ce922f42389004648b HTTP/1.1" 503 0
INFO:swiftclient:REQ: curl -i http://127.0.0.1:8080/v1/AUTH_c36b8bb29ea947ce922f42389004648b -I -H "X-Auth-Token: MIIEzwYJKoZIhvcNAQcCoIIEwDCCBLwCAQExCTAHBgUrDgMCGjCCAyUGCSqGSIb3DQEHAaCCAxYEggMSeyJhY2Nlc3MiOiB7InRva2VuIjogeyJpc3N1ZWRfYXQiOiAiMjAxNS0wMi0xOVQxNjoyNDoyMi4zNDg2ODgiLCAiZXhwaXJlcyI6ICIyMDE1LTAyLTE5VDE3OjI0OjIyWiIsICJpZCI6ICJwbGFjZWhvbGRlciIsICJ0ZW5hbnQiOiB7ImRlc2NyaXB0aW9uIjogIkFkbWluIFRlbmFudCIsICJlbmFibGVkIjogdHJ1ZSwgImlkIjogImMzNmI4YmIyOWVhOTQ3Y2U5MjJmNDIzODkwMDQ2NDhiIiwgIm5hbWUiOiAiYWRtaW4ifX0sICJzZXJ2aWNlQ2F0YWxvZyI6IFt7ImVuZHBvaW50cyI6IFt7ImFkbWluVVJMIjogImh0dHA6Ly8xMjcuMC4wLjE6ODA4MC92MSIsICJyZWdpb24iOiAiUmVnaW9uT25lIiwgImludGVybmFsVVJMIjogImh0dHA6Ly8xMjcuMC4wLjE6ODA4MC92MSIsICJpZCI6ICI0NTJlZmM4MTQwMTE0ZDQ0YTA0ZTI1MmU3YjA5NDVlYSIsICJwdWJsaWNVUkwiOiAiaHR0cDovLzEyNy4wLjAuMTo4MDgwL3YxL0FVVEhfYzM2YjhiYjI5ZWE5NDdjZTkyMmY0MjM4OTAwNDY0OGIifV0sICJlbmRwb2ludHNfbGlua3MiOiBbXSwgInR5cGUiOiAib2JqZWN0LXN0b3JlIiwgIm5hbWUiOiAic3dpZnQifV0sICJ1c2VyIjogeyJ1c2VybmFtZSI6ICJhZG1pbiIsICJyb2xlc19saW5rcyI6IFtdLCAiaWQiOiAiYTJiOGUyM2VhYTQwNDM3OGIyZmIzNGNmMjE3ZWZiZTkiLCAicm9sZXMiOiBbeyJuYW1lIjogImFkbWluIn1dLCAibmFtZSI6ICJhZG1pbiJ9LCAibWV0YWRhdGEiOiB7ImlzX2FkbWluIjogMCwgInJvbGVzIjogWyJlM2M0ODBjMmZkNjE0MmY1OTRiODUzOWIwMDJhNmI2ZCJdfX19MYIBgTCCAX0CAQEwXDBXMQswCQYDVQQGEwJVUzEOMAwGA1UECAwFVW5zZXQxDjAMBgNVBAcMBVVuc2V0MQ4wDAYDVQQKDAVVbnNldDEYMBYGA1UEAwwPd3d3LmV4YW1wbGUuY29tAgEBMAcGBSsOAwIaMA0GCSqGSIb3DQEBAQUABIIBAGEk0eY7g5pR3W6AEq1X5gpoP9lEXGWQbYYkZcHehxUTUkQsGOBoLGYg7bna737fwF7XB1JcsXjVj-swLYMlS7h2mnvjWHRbaeLVL03EL-cFmZ03fOVu+OrOjgnRYjrh+-1RToUd1wR3VYVdDM6G+1PxCm79E6cv6oNzyc5kj1hBOnXxXtCmtemD-NUFtR2qAEmOfajhJPLtCIqn4gzIftTtcEkULj0COFZEIP7vQplIGmgEdQNLYyY33dFvsLP86jU30jd0bIdr8VscqwjpL6ib7hEXlf-xhoYm45wEZvOo29Cxw3VekXto8zSNSmFucUE2bZWJILGSAtiKA1IzxOY="
INFO:swiftclient:RESP STATUS: 503 Internal Server Error
INFO:swiftclient:RESP HEADERS: [('date', 'Thu, 19 Feb 2015 16:24:53 GMT'), ('content-length', '0'), ('content-type', 'text/html; charset=UTF-8'), ('connection', 'keep-alive'), ('x-trans-id', 'tx720b6eb7729047939bc80-0054e60e55')]
ERROR:swiftclient:Account HEAD failed: http://127.0.0.1:8080/v1/AUTH_c36b8bb29ea947ce922f42389004648b 503 Internal Server Error
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/swiftclient/client.py", line 1243, in _retry
    rv = func(self.url, self.token, *args, **kwargs ...
(more)
edit retag flag offensive close merge delete

Comments

It should be -l 127.0.0.1 in /etc/memcached.conf file. Is 127.0.0.1 your proxy system ip? Did you check it using ifconfig? Type ifup eth0 and see ip of eth0.

Varsha gravatar imageVarsha ( 2015-02-19 10:59:50 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-19 11:34:43 -0500

eugene.goldberg gravatar image

I made this adjustment, and I'm getting passed the 503 - now I'm hitting a 400 bad request error. I will post that as a separate question

edit flag offensive delete link more
0

answered 2015-12-12 13:53:25 -0500

https://bugs.launchpad.net/openstack-manuals/+bug/1525563 (https://bugs.launchpad.net/openstack-...)

/etc/swift/account-server.conf
/etc/swift/container-server.conf
/etc/swift/object-server.conf

Modify files above on storage nodes to have

[pipeline:main]
...
pipeline = recon account-server

and append

[filter:recon]
use = egg:swift#recon
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-19 10:26:04 -0500

Seen: 1,739 times

Last updated: Feb 19 '15