Ask Your Question
0

im able to ping between instance to external gateway of my router but im not able to ping google from my instance

asked 2015-02-19 07:33:14 -0500

updated 2015-02-19 23:27:01 -0500

Recently im installed devstack ice-house by using the link https://fosskb.wordpress.com/2014/04/12/openstack-icehouse-on-ubuntu-12-04-lts-single-machine-setup/ (https://fosskb.wordpress.com/2014/04/...) using single interface config

im able to create external network and internal network also able to create the instance

my instance ping the router interface of both internal and external but im not able to ping the base machine ( which openstack was installed machine )

and also im not able to set the external network gateway in router GUI mode

pls give suggestion to ping google from my instance

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2015-02-19 07:43:15 -0500

Hi vignesh, may be this is due to VM is blocking the data, Once run this command

#   iptables -F

in the VM and check it once by using

  ping VM_ip-address
edit flag offensive delete link more
0

answered 2015-02-19 22:35:57 -0500

updated 2015-02-19 22:48:20 -0500

Thanks both of you for the reply but i had done the both things but cant get the instance out

This is the URL i followed to create the network in GUI mode

https://www.edge-cloud.net/2014/01/openstack-vsphere-nsx-part5/ (https://www.edge-cloud.net/2014/01/op...)

In that URL (See Figure 23) SET GATEWAY for the external network

Im not able to set the external gateway ( Getting the error )

but my router interfaces both are UP only

please give suggestion to create the flat network or VLAN based network to access the google from instance

edit flag offensive delete link more

Comments

did you add the two rules (All ICMP and SSH) through the horizon to that VM?

For connecting and accessing the VM we have to add those two rules.

Saikiran Veeravarapu gravatar imageSaikiran Veeravarapu ( 2015-02-20 03:38:29 -0500 )edit
0

answered 2015-02-19 07:42:02 -0500

hey there,

to access the internet from an instance do the following things from the host machine

sudo iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
edit flag offensive delete link more

Comments

And be sure that you has enabled ip forwarding via sysctl.conf file

net.ipv4.ip_forward=1

and try to check your resolv.conf file if it empty you need to add at least one nameserver record, for example

/etc/resovl.conf

namesrver 8.8.8.8
Pavel Kutishchev gravatar imagePavel Kutishchev ( 2015-02-20 11:41:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2015-02-19 07:33:14 -0500

Seen: 1,234 times

Last updated: Feb 19 '15