vlan tag on physical NIC; how to setup quantum?

asked 2013-10-18 20:06:37 -0500

I've used various documentation to setup my test system and I gone all to the point that I can create a VM. However my VM is unable to obtain an IP address from dnsmasq and I suspect it has something to do with my current configuration. I've listed my current setting below in hopes it leads me to a the right path to troubleshoot the matter:

I have the following network setup on my server:

auto bond0
iface bond0 inet manual
    bond-mode active-backup
        bond-slaves none
    bond-miimon 100

# External traffice
auto bond0.10
iface bond0.10 inet static

# Mgmt traffic
auto bond0.11
iface bond0.11 inet static

# Int/VM traffic
auto bond0.12
iface bond0.12 inet static

As you can see my physical network are vlan tag from the physical switch port and this is the only way for me to reach them to manage.

I've setup my quantum as VLAN provider and It seems that I've "correctly" configured it properly however I cannot get my VM instance to reach DHCP/dnsmasq. I haven't been able to verify If my VM can reach external traffic since I have to solve the dnsmasq issue first

The following are output of my config:

root@server01:/etc/quantum# grep -v "#" dhcp_agent.ini
[DEFAULT]
debug = True
resync_interval = 5
interface_driver = quantum.agent.linux.interface.BridgeInterfaceDriver
ovs_use_veth = True
dhcp_driver = quantum.agent.linux.dhcp.Dnsmasq
use_namespaces = True
enable_isolated_metadata = False
enable_metadata_network = False
root@server01:/etc/quantum# grep -v "#" l3_agent.ini 
[DEFAULT]
debug = True
interface_driver = quantum.agent.linux.interface.BridgeInterfaceDriver
use_namespaces = True
handle_internal_only_routers = True
external_network_bridge = 
metadata_port = 9697
send_arp_for_ha = 3
periodic_interval = 40
periodic_fuzzy_delay = 5
root@server01:/etc/quantum# grep -v "#" metadata_agent.ini 
[DEFAULT]
auth_url = http://127.0.0.1:35357/v2.0
auth_region = RegionOne
admin_tenant_name = service
admin_user = quantum
admin_password = openstack-network
nova_metadata_ip = 127.0.0.1
nova_metadata_port = 8775
metadata_proxy_shared_secret = metadata_secret
root@server01:/etc/quantum# grep -v "#" plugins/linuxbridge/linuxbridge_conf.ini 
[VLANS]
tenant_network_type = vlan
network_vlan_ranges = physnet1:1000:2999
[DATABASE]
sql_connection = postgresql://quantum:quantum@127.0.0.1:5432/quantum
reconnect_interval = 2
[LINUX_BRIDGE]
physical_interface_mappings = physnet1:bond0.180
[AGENT]
polling_interval = 2
[SECURITYGROUP]
firewall_driver = quantum.agent.linux.iptables_firewall.IptablesFirewallDriver

My VM hangs at this moment in the console:

cloud-init start-local running: Sat, 19 Oct 2013 00:28:29 +0000. up 4.42 seconds
no instance data found in start-local
cloud-init-nonet waiting 120 seconds for a network device.
cloud-init-nonet gave up waiting for a network device.
ci-info: lo    : 1 127.0.0.1       255.0.0.0       .
ci-info: eth0  : 1 .               .               fa:16:3e:57:0c:e5
route_info failed

I understand that the above is a quantum-metadata-agent & dnsmasq but base off these config. It should theoretically work. I do suspect my overall network topology is the issue here.

Thank you

PS: all my apis, mgmt all listening to 127.0.0.1 (single node setup); Thanks

edit retag flag offensive close merge delete

Comments

did you create br-int and br-ex ? brctl addbr br-int brctl addbr br-ex check your quantum dhcp agent logs

sdo gravatar imagesdo ( 2013-12-14 04:34:11 -0500 )edit

@sdo, sorry to a really late response. I ended collapsing everything and switched to a GRE tunneling instead and everything worked as expected; in fact I have it now in prod.

enarciso gravatar imageenarciso ( 2014-06-04 17:28:07 -0500 )edit